We opened an SR (#10816764917) for the client disconnected from server issue and implemented the FTF (pre 11.2.3, bug-804028_Dev_FTF_11.2.2_MU2version.zip) on 45 workstations. The workstations don't seem to become unmanaged anymore, but it has only been 24 hours. However, we have had about over 10 instances today where the DLU (with volatile cache) process stopped working. After I log in as a cached user, the process starts working again and I can log in with DLU that's never been logged into the workstation. I'm curious if anyone has had these problems too?

I started with a generic computer image that didn't have zenworks. I did a fresh installation of Zenworks from the server. I replaced the two files with the two in the FTF zip. Client reads version 11.2.2.16219 MU2. We are currently testing this in a library with 45 laptops that are frequently used by many different users for the fist time.

Our PCs are setup to use a Zenworks DLU policy to login. We recieved a workstation login prompt for a student (implies that Zenworks failed to dynamically create a user account). We logged in as test accounts a few times OK. On one of the attempts, we received the workstation prompt too. The first time we saw it in our testing was with the account ATStudent. I believe the following area in the log corresponds to this failed login attemp:

[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [ZENIsServerAvailable entered] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [About to call Get Zone Config Servers:] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [ZMD] [] [Getting Session Capability] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [LocationConfigBasedService] [] [Server role Configuration not found] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [ZenCache] [] [(Thread 40) GetObject(deviceResponse:Registration, UserContext{_LocalId=SYSTEM; _RemoteId=843c3c60bd90114996bea448e5979a83}) called] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [ZenCache] [] [Process ZenworksWindowsService acquired the access mutex for object cache ] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [ZenCache] [] [Released the access mutex for object cache] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [ZenCache] [] [(Thread 40) GetObject returning C:\Program Files\Novell\ZENworks\cache\zmd\ZenCache\73251bb2-13d1-42e9-a6aa-a94130c53d23 in 2 ms] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [Returned from Get Zone Config Servers:] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [Zone configuration servers are:] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [No hosts returned from ZoneConfigManager- It seems all primary servers are down] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [Need to do Cache login now] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [ZENIsServerAvailable returning SUCCESS] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [ZENVerifyCache entered] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [My REALMISTRICT88] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [My UserNameATStudent] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [About to call VerifyCredentials ] [] []
[DEBUG] [02/22/2013 13:27:56.937] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [ VerifyCredentials entered ] [] []
[DEBUG] [02/22/2013 13:27:56.953] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [Key Count:4] [] []
[DEBUG] [02/22/2013 13:27:56.953] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [Username : wbsupport] [] []
[DEBUG] [02/22/2013 13:27:56.953] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [Username : jkonney] [] []
[DEBUG] [02/22/2013 13:27:56.968] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [Username : wbstudent] [] []
[DEBUG] [02/22/2013 13:27:56.984] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [Username : ebuckley] [] []
[DEBUG] [02/22/2013 13:27:57.000] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [ VerifyCredentials exited ] [] []
[DEBUG] [02/22/2013 13:27:57.000] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [Returned from VerifyCredentials ] [] []
[DEBUG] [02/22/2013 13:27:57.000] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [ About to call RemoveEntries for Invalid Attempts if Exceeded:] [] []
[DEBUG] [02/22/2013 13:27:57.000] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [Returned from RemoveEntryForInvalidAttempt] [] []
[DEBUG] [02/22/2013 13:27:57.000] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [status to be returned:FAILURE] [] []
[DEBUG] [02/22/2013 13:27:57.000] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [ZENVerifyCache exiting] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [ZENDestroySession entered] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [ZENLogout entered] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonLogout] [] [ZENLogout entered] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonLogout] [] [ZENLogout calling GetSession] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonLogout] [] [Calling ClearCasaCredentials] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [DeleteMiCasaCredential entered] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [DeleteMiCasaCredential returning] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [DeleteMiCasaCredential entered] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [Calling MiCasa.DeleteCredential] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [MiCasa.DeleteCredential using Luid value: 0:3551261] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [MiCasa.DeleteCredential took exception. The error code is: -803] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CasaHelper] [] [DeleteMicasaCredential failed for realm : .zcmSharedSecret] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [RemotingService] [] [Calling ClearAuthTokenCache] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [ClearAuthTokenCache entered] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [Calling AuthToken.CleanUpAuthTokenCache] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [AuthToken.CleanUpAuthTokenCache using Luid value: 0:3551261] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [AuthToken.CleanUpAuthTokenCache returned] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [CommonCasa] [] [ClearAuthTokenCache returning] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [SessionManager] [] [OnChange performing change event for session 3551261, with event: ZenworksLogout] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [Novell.Zenworks.Tess] [] [EventManager -- EventTrigger for ZenworksLogout has been called.] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [Novell.Zenworks.Tess] [] [EventManager -- EventTrigger for ZenworksLogout has been called.] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [BundleManager] [] [ZenUser Logout happened for session 3551261 Asking Async thread to delete the Appdata files from disk] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [ZMD] [] [Getting Session Capability] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [LocationConfigBasedService] [] [Server role Configuration not found] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [RegistrationManager] [] [Unable to update device status with any service] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [RegistrationModule] [] [ZenworksLogout for ] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [LocMgr] [] [Received event ZenworksLogout] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [40] [] [LocMgr] [] [SessionInfo(Name=, SessionId=, SessionType=console, isZoneAdmin=False, terminalSessionId=0] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [(Thread 39) PutObject(registrationrimaryUserInfo, UserContext{_LocalId=SYSTEM; _RemoteId=843c3c60bd90114996bea448e5979a83}) called] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [Calling synchronous put for registrationrimaryUserInfo] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [Process ZenworksWindowsService acquired the access mutex for object cache ] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [Released the access mutex for object cache] [] []
[DEBUG] [02/22/2013 13:28:03.687] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [Type: System.Collections.Hashtable] [] []
[DEBUG] [02/22/2013 13:28:03.703] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [Process ZenworksWindowsService acquired the access mutex for object cache ] [] []
[DEBUG] [02/22/2013 13:28:03.734] [1024] [ZenworksWindowsService] [32] [] [LocMgr] [] [Entering SessionList] [] []
[DEBUG] [02/22/2013 13:28:03.734] [1024] [ZenworksWindowsService] [32] [] [LocMgr] [] [Returning 0 Session(s)
] [] []
[DEBUG] [02/22/2013 13:28:03.750] [1024] [ZenworksWindowsService] [32] [] [LocMgr] [] [Entering OnConfigLocationChanged] [] []
[DEBUG] [02/22/2013 13:28:03.750] [1024] [ZenworksWindowsService] [32] [] [LocMgr] [] [LocationDecider.CurrentAssignedLocation returned: newLocId: 283b1618a8a7245e0c5739693dc20168; newLocName: Willowbrook; newNetEnvId: d727f4f0b6e17a54faf1e1c9d429afcf; newNetEnvName: Willowbrook)] [] []
[DEBUG] [02/22/2013 13:28:03.750] [1024] [ZenworksWindowsService] [32] [] [ZenCache] [] [(Thread 32) PutObject(LocMgr.StartUpConfigLoc, UserContext{_LocalId=none; _RemoteId=(Public)}) called] [] []
[DEBUG] [02/22/2013 13:28:03.750] [1024] [ZenworksWindowsService] [32] [] [ZenCache] [] [Calling synchronous put for LocMgr.StartUpConfigLoc] [] []
[DEBUG] [02/22/2013 13:28:03.796] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [Released the access mutex for object cache] [] []
[DEBUG] [02/22/2013 13:28:03.796] [1024] [ZenworksWindowsService] [39] [] [ZenCache] [] [(Thread 39) PutObject returning C:\Program Files\Novell\ZENworks\cache\zmd\ZenCache\60b3c79c-3f0b-47af-a8c8-48732c656479 in 105 ms] [] []


"No hosts returned from ZoneConfigManager- It seems all primary servers are down" Could this mean there is an issue with the DNS? Cached DNS? And after a cached user logs in it is refreshed?

Ideas welcome, thanks.