Hi

We have ZCM Version 10.3.0 running on SLES10 Servers in our setup.

We have 2 primary Servers, but all of a sudden the content role has disappeared on the first Server. So if you click Devices | Servers | SLES1 | Content (tab) it returns:

'No content status to display because device does not have a content role'

If I click Configuration | Primary Server Replication it only lists the second Server and not the first one.

Under Configuration | Server Hierarchy we also have the Sat Servers listed under both Primary Servers so nothing has changed.

My colleague noticed the problem adding a new bundle and we saw disk space on the first Server was around 1.3GB. So I cleared some space and it is now around 10GB free.

Since then I have created a new bundle and within the ZCC.LOG I have seen the following messages appear:

06 Mar 2013 08:36:25 ReplicationBaseSet..423 :Current replication mode set to: UNKNOWN
06 Mar 2013 08:45:28 ReplicationBaseSet..423 :Current replication mode set to: REPLICATION_ALL_SERVERS
06 Mar 2013 08:49:20 ReplicationBaseSet..423 :Current replication mode set to: REPLICATION_ALL_SERVERS
06 Mar 2013 09:36:25 ReplicationBaseSet..423 :Current replication mode set to: UNKNOWN


I have also tried renaming the content-repo folder on SLES1 and it does recreate itself and copy the content back across showing replication is working.

Finally if I run novell-zenworks-configure -c SystemStatus this error gets returned:


~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~

_______ _ _ _
|_ / __| \| Novell_____ _ _| |_____
/ /| _|| .` \ V V / _ \ '_| / (_-<
/___|___|_|\_|\_/\_/\___/_| |_\_Y__/ ~ v.10.3
================================================
ZENworks 10.3 Configuration Utility

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~




For each prompt presented, press 'enter' to accept the (default) value, type
'back' to return to the previous action, or type 'quit' to exit.

com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: java.io.EOFException
at com.novell.zenworks.datamodel.services.Certificate ManagerImpl.<init>(CertificateManagerImpl.java:113 )
at com.novell.zenworks.datamodel.services.Certificate ManagerImpl.getDefault(CertificateManagerImpl.java :78)
at com.novell.zenworks.datamodel.services.DirectServi ceStoreImpl.initialize(DirectServiceStoreImpl.java :143)
at com.novell.zenworks.datamodel.services.ServiceStor eFactory.factoryServiceStore(ServiceStoreFactory.j ava:182)
at com.novell.zenworks.datamodel.services.ServiceStor eFactory.factoryServiceStore(ServiceStoreFactory.j ava:153)
at com.novell.zenworks.configure.actions.SystemStatus ConfigureAction.configure(SystemStatusConfigureAct ion.java:191)
at com.novell.zenworks.configure.actions.SystemStatus ConfigureAction.configure(SystemStatusConfigureAct ion.java:157)
at com.novell.zenworks.configure.ZENworksConfigure.ex ecConfigAction(ZENworksConfigure.java:1327)
at com.novell.zenworks.configure.ZENworksConfigure.co nfigure(ZENworksConfigure.java:1184)
at com.novell.zenworks.configure.ZENworksConfigure.ma in(ZENworksConfigure.java:1103)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:592)
at com.novell.zenworks.configure.ConfigureLoader.main (ConfigureLoader.java:39)
Caused by: com.novell.zenworks.datamodel.exceptions.InternalD ataModelException: java.io.EOFException
at com.novell.zenworks.datamodel.services.Certificate ManagerImpl.reloadKeyStore(CertificateManagerImpl. java:172)
at com.novell.zenworks.datamodel.services.Certificate ManagerImpl.<init>(CertificateManagerImpl.java:109 )
... 14 more
Caused by: java.io.EOFException
at java.io.DataInputStream.readInt(DataInputStream.ja va:358)
at sun.security.provider.JavaKeyStore.engineLoad(Java KeyStore.java:627)
at java.security.KeyStore.load(KeyStore.java:1150)
at com.novell.zenworks.datamodel.services.Certificate ManagerImpl.reloadKeyStore(CertificateManagerImpl. java:160)
... 15 more
SEVERE: null
<>


Any help or advice would be greatly appreciated.

Regards,
Ant