We installed 11.2.2 via the Nov 8th release - upgrade manual import.
When this happened a bug with the installer (permissions) failed to install properly.
We ended up opening a SR and Novel fixed the ZCm primary server - but only half of it app

Now we are trying to install the 11.2.2 MU - and it won't install - pre-requisites not met
We noticed the zenworks adaptive agent on the primary server (certain agent components) are all at different levels
Bundle - 11.2.2
Image management 11.2.2
inventory 11.2.0
patch management
policy 11.2.0
remote 11.2.0

What should we do as it is not allowing us to upgrade or patch?

Thanks Joe