I didn't see it when I ran a Google search, so I thought it might be good to post this.

I am working on an application that requires the bundle to copy .ica files from one directory to another. After I discovered that xcopy didn't support wildcards, I turned to robocopy. Unfortunately, I kept getting a rather mysterious error about the script not working.

I used a Launch Executable action to run robocopy with the following fields:


Command line parameters:
"${ProgramFiles32}\SourceDir" "${WinDisk}\TargetDir" *.ica

Working directory:

X - Wait until action is complete
X - Run as secure system user
And when I ran it this time, I got an exit code... 1. I looked this up on Google, and lo and behold...

Hex Decimal Meaning if set
001 1 One or more files were copied successfully (that is, new files have arrived).
This causes ZCM to fail. Therefore, it's important to put "1" into the Success Return Codes field. To be totally on the safe side, I put "0,1,2" into the field.

Just a tip if anyone runs into the same problem I did.