Home

Results 1 to 10 of 10

Thread: OpenSUSE 12.3 and iFolder

Threaded View

  1. #1

    OpenSUSE 12.3 and iFolder

    Anybody managed to get the most recent iFolder running on openSUSE 12.3 yet? I keep getting mono errors from what I gathered its because its complied for a different version of mono...

    Anybody got any info on this? Or have a I just missed a dependency? The log below is what i get when it launches.

    Code:
    Missing method System.Type::op_Equality(Type,Type) in assembly /usr/lib/mono/2.0/mscorlib.dll, referenced in assembly /usr/lib/mono/gac/gnome-sharp/2.24.0.0__35e10195dab3c99f/gnome-sharp.dll
    
    (process:4535): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()
    
    (process:4535): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed
    
    (process:4535): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()
    
    (process:4535): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()
    
    (process:4535): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()
    
    (process:4535): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
    
    (process:4535): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()
    
    (process:4535): GLib-GObject-CRITICAL **: g_type_interface_add_prerequisite: assertion `G_TYPE_IS_INTERFACE (interface_type)' failed
    
    (process:4535): GLib-CRITICAL **: g_once_init_leave: assertion `result != 0' failed
    
    (process:4535): GLib-GObject-CRITICAL **: g_type_add_interface_static: assertion `G_TYPE_IS_INSTANTIATABLE (instance_type)' failed
    
    (process:4535): GLib-GObject-CRITICAL **: gtype.c:2720: You forgot to call g_type_init()
    It talks about a sharp lib at top which I made sure I have but still cant get it working. Some assistance on this would be great if anybody managed it.

    I did find this and try it only to get another error about CLI image.

    http://orangesquash.org.uk/~laney/bl...0/mono-gotcha/

    Thats the article that says its a mono problem because it was compiled for old version.

    Thanks
    William
    Last edited by williamfleming; 17-Apr-2013 at 01:59 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •