I have an interesting problem. We are working on upgrading from 11.2.1 to 11.2.3a.

I have a spreadsheet that has a list of all users and the device name (red tag) that they are assigned to in our inventory system.
While assigning out this system update, I am coming across some users who for some reason have a primary workstation, but that workstation is really one that someone else is logging into daily. When I search the Devices for the users correct machine name (red tag) there are no results returned. If I go to the user's desk and check their ZAA, the device is managed, on the right zone, etc. AND their workstation device name shows their correct red tag. The only way to get ZEN to recognize this device is to do a zac unr -f. Once the device is unregistered from the ZONE (Not un registered locally only) then I do a zac reg https://servername.domain.com, enter my user name and password and once its registered, everything is fine. The device now shows up in the devices section again. (Doing this is not that big of a deal, however I do have to physically touch the machine to do this.)

My question is:

Is there an easier way to script the unreg and rereg with my credentials securely? If I do this in a .bat file, if the user is smart enough they can right click and edit to see my credentials. I can't really push a bundle that I know of, since their machine technically doesn't exist in the devices section.

I would like to maybe just be able to send them a script via e-mail to have them run once and it does the un reg and rereg automatically so they can receive the system update as soon as their device is properly registered again.