I am attempting to update from oes 11 to oes 11 sp 1 using zypper. I ran the zypper up -t patch until all updates were complete (nothing to do). Then I ran the zypper in -t to install the the migration packages. I disabled old packages and enabled new packages. I then ran the zypper dup and received the output before. What is the recommended option to select or what should i do to resolve the issue.

/Desktop # zypper dup
Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
Loading repository data...
Reading installed packages...
Computing distribution upgrade...
21 Problems:
Problem: nothing provides liblzma.so.5()(64bit) needed by deltarpm-3.5.git-4.9.3.x86_64
Problem: nothing provides liblzma.so.5()(64bit) needed by libdw1-0.152-4.7.86.x86_64
Problem: nothing provides liblzma.so.5()(64bit) needed by rpm-python-4.4.2.3-37.46.7.x86_64
Problem: nothing provides mozilla-xulrunner192 needed by yelp-2.28.1-1.9.2.7.x86_64
Problem: nothing provides tunctl needed by sysconfig-0.71.47-0.7.1.x86_64
Problem: nothing provides liblzma.so.5()(64bit) needed by rpm-4.4.2.3-37.46.15.x86_64
Problem: nothing provides xz needed by mkinitrd-2.4.2-0.49.2.x86_64
Problem: nothing provides liblzma.so.5()(64bit) needed by libdw1-0.152-4.7.86.x86_64
Problem: nothing provides liblzma.so.5()(64bit) needed by libdw1-0.152-4.7.86.x86_64
Problem: nothing provides liblzma.so.5()(64bit) needed by libdw1-0.152-4.7.86.x86_64
Problem: nothing provides libpython2.6.so.1.0 needed by novell-oes-samba-libtalloc2-32bit-3.6.3-16.1.x86_64
Problem: nothing provides libpython2.6.so.1.0 needed by novell-oes-samba-libtalloc2-32bit-3.6.3-16.1.x86_64
Problem: nothing provides xz needed by mkinitrd-2.4.2-0.49.2.x86_64
Problem: nothing provides xz needed by mkinitrd-2.4.2-0.49.2.x86_64
Problem: nothing provides xz needed by mkinitrd-2.4.2-0.49.2.x86_64
Problem: nothing provides xz needed by mkinitrd-2.4.2-0.49.2.x86_64
Problem: nothing provides xz needed by mkinitrd-2.4.2-0.49.2.x86_64
Problem: nothing provides xz needed by mkinitrd-2.4.2-0.49.2.x86_64
Problem: novell-nwmpk-kmp-default-1.5.4519_3.0.13_0.27-0.2.4.x86_64 requires kernel(default:arch_x86_kernel_x8664_ksyms_64) = 2af1e5a3b31ce371, but this requirement cannot be provided
Problem: novell-zapi-kmp-default-1.5.4519_3.0.13_0.27-0.2.5.x86_64 requires kernel(default:arch_x86_kernel_x8664_ksyms_64) = 2af1e5a3b31ce371, but this requirement cannot be provided
Problem: nss-kmp-default-4.15.4519_3.0.13_0.27-0.2.5.x86_64 requires kernel(default:arch_x86_kernel_x8664_ksyms_64) = 2af1e5a3b31ce371, but this requirement cannot be provided

Problem: nothing provides liblzma.so.5()(64bit) needed by deltarpm-3.5.git-4.9.3.x86_64
Solution 1: keep obsolete deltarpm-3.4-103.22.x86_64
Solution 2: break deltarpm by ignoring some of its dependencies

Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):