I have some bundles that are used for software installation at night - for example updating Java and Novell Client. These bundles have a distribution schedule set for some determined time at night, and "Wake on LAN", "Install immediately after distribution" and "Launch immediately after installation" checkboxes are checked. This has been working quite well, these bundles have been in use for over a year and I've used them for updating Java and Novell Client several times.

But now something has happened... The workstations are still started by WoL as specified in the schedule, but bundle installation and launch are not happening. When viewing the bundle distribution status in ZCC, it shows "pending" for all machines. There are no messages in ZCC about why the bundles are not distributed/installed/launched. I have also tried looking at the agent log on local machines but this log is quite overwhelming and I haven't been able to find any clues about the problem there.

I tried running "zac cc" on some machines, but this didn't help. I also published one of these stubborn bundles as new bundle, but the new bundle still has the same problem.

If I launch the bundle manually, it works as expected.

I did, however, find a workaround. I set the launch schedule for these bundles to "on device refresh" and availability schedule to some night hours. Then I created another bundle named "WoL". This bundle itself does nothing, but I defined a distribution schedule for some time at night and checked "Wake on LAN" and "Install immediately after distribution". This gives me what I want - the WoL bundle wakes up the machine, then the agent performs a refresh and the software installation bundle is launched.

But it is strange that such workaround is needed. I haven't done any changes in my ZCM infrastructure for quite some time (its ZCM 11 SP1), so it's interesting what broke...