Hi,

the system affected is a virtual machine running on XEN - it's a SLES11SP2 OES11SP1 with GroupWise 2012 installed. I applied the latest security patches which included kernel upgrades to version 3.0.80.

After a restart nss would not load - it could not load the nsscomn.ko module.

From /var/log/boot.msg:
Code:
loading nsscomn kernel module
FATAL: Error inserting nsscomn (/lib/modules/3.0.80-0.5-xen/weak-updates/updates/nsscomn.ko): Operation not permitted
ERROR: Failed load of nsscomn
.......... ABORTING /etc/init.d/rc3.d/S13novell-nss ..........
/opt/novell/nss/sbin/startnss.bsh: line 344:  5431 Killed                  bash ${NSS_TZ}
nss: Failed to set the NSS_TZOffset, returned  137
mknod: missing operand after `0'
Try `mknod --help' for more information.
chgrp: cannot access `/dev/zapi': No such file or directory
chmod: cannot access `/dev/zapi': No such file or directory
Scan devices and mount pools
<notice -- Jun 21 11:22:50.868442000> checkproc: /usr/sbin/namcd 4127
NSS is NOT fully running!
<notice -- Jun 21 11:22:51.203043000> 
'novell-nss start' exits with status 7
From /var/log/messages:
Code:
Jun 21 09:34:28 gw1 kernel: [   58.536569] COMN::/usr/src/packages/BUILD/nss/modules-build/comn/comnLKM.c[198]
Jun 21 09:34:28 gw1 kernel: [   58.536955]  MaxBuffer_s = 1838130
Jun 21 09:34:28 gw1 kernel: [   58.575017]  NumPagesToWait = 459532
Jun 21 09:34:28 gw1 kernel: [   58.658556]  Error return from addACacheBuffer
Jun 21 09:34:28 gw1 kernel: [   58.669004] There is no stop!
Jun 21 09:34:28 gw1 kernel: [   58.673480] nss: comnLKM[166]: status=-1
Jun 21 09:34:28 gw1 kernel: [   58.673484] COMN::/usr/src/packages/BUILD/nss/modules-build/comn/comnLKM.c[200]=-1
Jun 21 09:34:28 gw1 kernel: [   58.717664] BUG: unable to handle kernel paging request at ffffffffa05fcf68
Jun 21 09:34:28 gw1 kernel: [   58.717683] IP: [<ffffffff802175d8>] strcmp+0x8/0x30
Jun 21 09:34:28 gw1 kernel: [   58.717699] PGD 794067 PUD 224b067 PMD 192a80067 PTE 0
Jun 21 09:34:28 gw1 kernel: [   58.717710] Oops: 0000 [#1] SMP 
Jun 21 09:34:28 gw1 kernel: [   58.717719] CPU 0 
Jun 21 09:34:28 gw1 kernel: [   58.717722] Modules linked in: ndpmod nss nsslibrary nsslnxlib libnss admindrv nwraid tcp_diag inet_diag fuse 
nls_utf8 xfs dm_crypt loop dm_mod ipv6_lib joydev scsi_dh_rdac scsi_dh_emc scsi_dh_hp_sw scsi_dh_alua scsi_dh xennet ext3 mbcache jbd process
or thermal_sys hwmon xenblk cdrom ata_generic ata_piix libata scsi_mod
Jun 21 09:34:28 gw1 kernel: [   58.717779] Supported: Yes
Jun 21 09:34:28 gw1 kernel: [   58.717782] 
Jun 21 09:34:28 gw1 kernel: [   58.717786] Pid: 5492, comm: bash Not tainted 3.0.80-0.5-xen #1  
Jun 21 09:34:28 gw1 kernel: [   58.717793] RIP: e030:[<ffffffff802175d8>]  [<ffffffff802175d8>] strcmp+0x8/0x30
Jun 21 09:34:28 gw1 kernel: [   58.717801] RSP: e02b:ffff880190407ec0  EFLAGS: 00010246
Jun 21 09:34:28 gw1 kernel: [   58.717805] RAX: 0000000000000000 RBX: ffff880192a8d800 RCX: 0000000000000000
Jun 21 09:34:28 gw1 kernel: [   58.717810] RDX: 000000004400000e RSI: ffffffffa037adf8 RDI: ffffffffa05fcf68
Jun 21 09:34:28 gw1 kernel: [   58.717816] RBP: ffffffffa037adf8 R08: ffff8801ad702cc0 R09: ffff88019629b460
Jun 21 09:34:28 gw1 kernel: [   58.717820] R10: 00007f2224860e30 R11: 0000000000000246 R12: ffff880192a8d800
Jun 21 09:34:28 gw1 kernel: [   58.717825] R13: 00007f2224ec7000 R14: 00007fff608ed9a0 R15: 0000000000000000
Jun 21 09:34:28 gw1 kernel: [   58.717834] FS:  00007f2224e81700(0000) GS:ffff8801b8c00000(0000) knlGS:0000000000000000
Jun 21 09:34:28 gw1 kernel: [   58.717840] CS:  e033 DS: 0000 ES: 0000 CR0: 0000000080050033
Jun 21 09:34:28 gw1 kernel: [   58.717844] CR2: ffffffffa05fcf68 CR3: 00000001917d6000 CR4: 0000000000002660
Jun 21 09:34:28 gw1 kernel: [   58.717850] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jun 21 09:34:28 gw1 nss: Failed to set the NSS_TZOffset, returned  137
Jun 21 09:34:29 gw1 kernel: [   58.717856] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jun 21 09:34:29 gw1 kernel: [   58.717864] Process bash (pid: 5492, threadinfo ffff880190406000, task ffff8801917fe740)
Jun 21 09:34:29 gw1 kernel: [   58.717869] Stack:
Jun 21 09:34:29 gw1 kernel: [   58.717872]  ffffffffa01ec63d 00000007f2224ec7 ffff8801b2f54400 0000000000000013
Jun 21 09:34:29 gw1 kernel: [   58.717882]  ffffffffa037adf8 00007f2224ec7000 ffffffffa036bfd8 0000000000000013
Jun 21 09:34:29 gw1 kernel: [   58.717892]  ffff8801ad702cc0 ffff880190407f50 ffffffff80129d0e 00000000ffffffff
Jun 21 09:34:29 gw1 kernel: [   58.717901] Call Trace:
Jun 21 09:34:29 gw1 kernel: [   58.717927]  [<ffffffffa01ec63d>] nss_get_module+0x38/0x191 [libnss]
Jun 21 09:34:29 gw1 nlvm: mount output: mount: unknown filesystem type 'nsspool'
Jun 21 09:34:29 gw1 kernel: [   58.717959]  [<ffffffffa036bfd8>] device_write+0x6a/0xad [nsslibrary]
Jun 21 09:34:29 gw1 kernel: [   58.717993]  [<ffffffff80129d0e>] vfs_write+0xce/0x140
Jun 21 09:34:29 gw1 kernel: [   58.718003]  [<ffffffff80129e83>] sys_write+0x53/0xa0
Jun 21 09:34:29 gw1 kernel: [   58.718014]  [<ffffffff80402da3>] system_call_fastpath+0x16/0x1b
Jun 21 09:34:29 gw1 kernel: [   58.718024]  [<00007f22245ba1f0>] 0x7f22245ba1ef
Jun 21 09:34:29 gw1 kernel: [   58.718031] Code: 1f 40 00 42 0f b6 04 06 84 c0 88 01 74 10 49 83 c0 01 48 83 c1 01 4c 39 c2 75 e8 c6 01 00 48
 89 f8 c3 90 31 c0 66 0f 1f 44 00 00 <0f> b6 14 07 3a 14 06 75 0f 48 83 c0 01 84 d2 75 ef 31 c0 c3 0f 
Jun 21 09:34:29 gw1 kernel: [   58.718105] RIP  [<ffffffff802175d8>] strcmp+0x8/0x30
Jun 21 09:34:29 gw1 kernel: [   58.718113]  RSP <ffff880190407ec0>
Jun 21 09:34:29 gw1 kernel: [   58.718117] CR2: ffffffffa05fcf68
Jun 21 09:34:29 gw1 kernel: [   58.718122] ---[ end trace 74f5e9c673e42e1d ]---
Jun 21 09:34:29 gw1 kernel: [   59.528718]  xvdb: xvdb1
I downgraded the kernel to the previous version. NSS works fine again.

Is there a way to fix that issue? Shall I report this bug somewhere?

Mike