We had an Internal certificate expiration message recently even though the server certificates were not set to expire until 2021. We replaced the Internal certificate by running the novell-zenworks-configure -c SSL -Z command on the primary server (we only have one primary server) We restarted all of the services after running this command by running the novell-zenworks-configure -c Start command. The CA certificate was not changed just the Primary Server certificate. This did remove the warning message we kept getting that our certificate was going to expire in X amount of days.

We found after doing this we were unable to manage any of the device in the managed zone. I ran the zac retr -u (admin user name) -p (admin password) command on one of the devices in the zone, then attempted to remote control the device and received the message "Rights Authentication failed. The ticket could not be verified by the ZENworks server. Contact Novell Technical Services." I looked up certificate information by running zac cert-info on the managed device that I had just run zac retr on and all of the certificate info looked good (host by name and ip address) except the initial-web-service, it still had the old certificate information. I'm not sure if that has anything to do with the authentication error I am receiving. I also unregistered and reregistered the device to the managed zone but am still receiving the rights error message when trying to remote control the device.

I did note that in the instruction on this page: Novell Doc: ZENworks 11 SP2 Disaster Recovery Reference - Replacing an Internal Server Certificate with a New Internal Server Certificate State to run this command on the Authentication Satellites: zac authentication server reconfigure (asr) -t all. Is this something I would need to worry about since the only satellite server I have is an imaging server? Also, It state I need to Re-create all the default and custom deployment packages for the Primary Servers. We use the Default Deployment Package so I want to run the command novell-zenworks-configure -c CreateExtractorPacks -z but when I run that command it say that -z requires an argument. The help that is generated on this says the -Z = force All ConfigureActions to ignore previous configurations. (default false). I am unsure what argument I would put with that.

Any assistance anyone can provide would be greatly appreciated!