Results 1 to 1 of 1

Thread: Invalid Pointer in Object API with .NET

Threaded View

  1. #1

    Invalid Pointer in Object API with .NET


    I am reading GroupWise archives with Object API in C# .NET.
    I have a Windows Application project that does the business logic, and a WPF project for GUI stuff.

    when I run my Windows App project, it works fine, however when I run my project from GUI I get an error "An invalid pointer was used" on this line of code:

    Account archAcc = (acc as Account6).GetArchiveAccount();

    I can run my Windows App both with STA and MTA threading modes, but the WPF imposes STA mode.

    I have tried writing my code in many ways for reading archives including BackgroundWorker, Async Programming, running on a new thread, running from UI dispatcher thread but have the same problem.

    anyone have any idea on this?
    Last edited by mojtabae; 15-Aug-2013 at 09:10 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts