Home

Results 1 to 3 of 3

Thread: Failed adding slave server

Hybrid View

  1. #1
    Join Date
    Mar 2008
    Posts
    64

    Failed adding slave server

    I have iFolder 3.7.1 running on SLES 10 OES 2. I'm wanting to add a ifolder slave server running SLES 11 SP2 OES 11 SP1. Once I have the slave in place I plan to reprovision users to the slave before upgrading the the master. While trying the add the slave I received the message that the iFolder failed to install. Looking in the /var/log/yast2/y2log I have found the error failed to communicate to master, unable to retrieve the certificate from the ifolder server. I have pasted the log below. Any help would be much appreciated.


    2013-09-03 14:15:43 <1> ifolder(21383) [YCP] NovellIfolder3.ycp:1110 ifolder3.write:executing: /opt/novell/ifolder3/bin/simias-server-setup --p='/ifolder/var/simias/data' --listen-port=443 --server-name=ifolder --public-url='https:10.xx.xx.2:443/simias10' --private-url='https://10.xx.xx.2:443/simias10' --ldap-plugin=true --use-ssl='BOTH' --slave-server=true --master-address=https://10.xx.xx.3:443/simias10 --use-ldap=true --ldap-server=10.xx.xx.14:636 --ldap-ssl=false --ldap-admin-dn='cn=arc***,o=klc' --system-admin-dn='cn=arc***,o=klc' --system-admin-dn='cn=arc***,o=klc' --ldap-proxy-dn='cn=OESCommonProxy_ifolder,ou=HQ,o=KLC' --ldap-search-context='ou=HQ,o=KLC#o=klc' --apache=true --use-recovery-agent=true --ra-cert-path='/ifolder/var/simias/data/simias' --ldap-cert-acceptance=true
    2013-09-03 14:15:43 <1> ifolder(21383) [YCP] NovellIfolder3.ycp:1112 ifolder3.write::config output:Map Value:
    $["exit":255, "stderr":"", "stdout":"\nSIMIAS SERVER SETUP\n\nPrivate https://10.xx.xx.2:443/simias10\n\n\n\nonslave : setting to true\n\n\nWorking...\n\nInside SetupLdapCert\nInstalling certificate from ldap://10.xx.xx.14:636/...\n\nSkipped (Not Supported)\nFailed to connect to master server, Slave setup failed.\nCheck iFolder server is running on master server.\nUnable to retrieve the certificate from the iFolder server..\n.. at Novell.iFolder.SimiasServerSetup.SetupSSL () [0x00000] in <filename unknown>:0 \n at Novell.iFolder.SimiasServerSetup.ParseArguments () [0x00000] in <filename unknown>:0 \n"]
    2013-09-03 14:15:43 <3> ifolder(21383) [YCP] NovellIfolder3.ycp:1117 Warning: Failed to configure Novell iFolder 3 Server
    2013-09-03 14:15:43 <3> ifolder(21383) [YCP] Report.ycp:523 Failed to configure Novell iFolder 3 Server

  2. #2
    Join Date
    Mar 2008
    Posts
    64

    Re: Failed adding slave server

    I tried to do the install using simias-server-setup and received the following error (same as through YAST2)

    Failed to connect to master server, Slave setup failed.
    Check iFolder server is running on master server.
    Unable to retrieve the certificate from the iFolder server..
    .. at Novell.iFolder.SimiasServerSetup.SetupSSL () [0x00000] in <filename unknown>:0
    at Novell.iFolder.SimiasServerSetup.ParseArguments () [0x00000] in <filename unknown>:0

  3. #3
    Join Date
    Mar 2013
    Posts
    1

    Re: Failed adding slave server

    Same problem here. Did you find a solution for this issue ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •