When trying the upgrade to NSM agent 3.1.1 on SLES 10 Sp4 x64 servers, I receive the following:

error: Failed dependencies:
libxml2.so.2(LIBXML2_2.4.30)(64bit) is needed by novell-storagemanager-agent-3.1.1-17.x86_64
libxml2.so.2(LIBXML2_2.5.2)(64bit) is needed by novell-storagemanager-agent-3.1.1-17.x86_64
libxml2.so.2(LIBXML2_2.6.0)(64bit) is needed by novell-storagemanager-agent-3.1.1-17.x86_64


I checked and both libxml2 and libxml2-32bit (version 2.6.23) are installed. The Engine and Event installed without issue.

The version upgrading from is 3.0.3-18.