We are having a little bit of difficulty with our client updates. We had deployed the update for 11.2.3a and every device has since been updated, after which we did 11.2.3a Monthly Update 1 (MU1), but one of the other IT team members went and deleted the 11.2.3a off the server and so some of the devices did not get MU1. Also some devices required Zenworks to be reinstalled and still didn't get MU1 after we returned 11.2.3a to the server. We decided to Abort MU1 and redeploy 11.2.3a and even though all devices are updated we have 5 that are straggling behind and are stuck with "Update Assigned" for their status and yet the device summary on some are on 11.2.3a and some are on MU1.

I have tried clearing the cache on the devices (zac cc), left them running over night (as some others took awhile to change to "Successful"), and also tried refreshing the devices multiple times to no avail. Any and all help would be appreciated.

Also, does it make a difference if all the devices are on MU1 or not?