We have a customer currently on GW2012 who is using the old Novell OpenOffice release (3.2.1-22 IIRC) to integrate with GroupWise Document Libraries. To cut a long story short it is not a rewarding experience for the customer and they want to switch to using Microsoft Office.

So my question is simple - Which version(s) of Microsoft Office are supported by Novell to work with DMS integration for GroupWise 2012?

I know they need to be 32bit for ODMA support to even exist but are we talking Office 2007/2010/2013, any of them or none? If nothing is supported any longer then why is DMS even included in GW2012? Moving them to Vibe would be a big ask.
If this customer buys Microsoft Office and has issues using it with their GW system then we need to be able to raise an SR with Novell and not get a "that's not supported" answer.