Anyone else having issues with the group policy editor and IE 11? I can't find something simple telling me the browser support in different versions of ZCM 11 and what is tested and working or not.

I'm running 11.2.2 mu2 at the moment and want to find out what version i should be updating to for ie11 support. I'm assuming the latest, but wanted to clarify if its actually supported or whether I should roll back to IE 10 or something