Home

Results 1 to 10 of 37

Thread: Problem with namcd

Threaded View

  1. #1
    Join Date
    Mar 2008
    Location
    Hannover, Germany
    Posts
    114

    Problem with namcd

    Hello.

    I've got a problem with e-Mailserver (Sles11 X86_64 SP1 with OES11, eDir 8.8 Sp7, Kernel-default-base-2.6.32.59-0.7.1)
    On startup there are many messages on screen.

    /var/og/messages:
    Dec 19 12:32:02 MYSERVER dbus-daemon-launch-helper: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:32:02 MYSERVER hald[3026]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:32:02 MYSERVER hald[3026]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:32:11 MYSERVER kernel: [ 79.647218] e1000e: eth4 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX/TX
    Dec 19 12:32:11 MYSERVER sshd[4555]: Server listening on 0.0.0.0 port 22.
    Dec 19 12:32:12 MYSERVER smdrd[4493]: Target name MYSERVER successfully advertised with SLP
    Dec 19 12:32:12 MYSERVER ntpd[4574]: ntpd 4.2.4p8@1.1612-o Tue Dec 20 21:31:16 UTC 2011 (1)
    Dec 19 12:32:12 MYSERVER ntpd[4576]: precision = 1.000 usec
    Dec 19 12:32:12 MYSERVER ntpd[4576]: ntp_io: estimated max descriptors: 1024, initial socket boundary: 16
    Dec 19 12:32:12 MYSERVER ntpd[4576]: Listening on interface #0 wildcard, 0.0.0.0#123 Disabled
    Dec 19 12:32:12 MYSERVER ntpd[4576]: Listening on interface #1 lo, 127.0.0.1#123 Enabled
    Dec 19 12:32:12 MYSERVER ntpd[4576]: Listening on interface #2 lo, 127.0.0.2#123 Enabled
    Dec 19 12:32:12 MYSERVER ntpd[4576]: Listening on interface #3 eth4, 192.168.1.205#123 Enabled
    Dec 19 12:32:12 MYSERVER ntpd[4576]: kernel time sync status 2040
    Dec 19 12:32:12 MYSERVER ntpd[4576]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:32:12 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:32:13 MYSERVER smdrd[4493]: Loading TSA tsafs
    Dec 19 12:32:13 MYSERVER smdrd[4493]: NCSLIB: Error -1 opening /var/opt/novell/ncs/cluster.xml
    Dec 19 12:32:13 MYSERVER smdrd[4493]: Module tsafs successfully loaded
    Dec 19 12:32:16 MYSERVER ndsd[4740]: [Info]ChangeVolumeStatus volume SYS mounted
    Dec 19 12:32:16 MYSERVER ndsd[4740]: [Info]ChangeVolumeStatus volume GRPWISE mounted
    Dec 19 12:32:19 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:32:20 MYSERVER su: (to wwwrun) root on none
    Dec 19 12:32:20 MYSERVER su: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:32:25 MYSERVER ntpd[4576]: synchronized to 192.168.1.227, stratum 2
    Dec 19 11:32:26 MYSERVER ntpd[4576]: time reset -3598.500462 s
    Dec 19 11:32:26 MYSERVER ntpd[4576]: kernel time sync status change 2001
    Dec 19 11:32:47 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:33:24 MYSERVER /usr/sbin/namcd[7087]: main: Daemonizing namcd
    Dec 19 11:33:24 MYSERVER /usr/sbin/namcd[7087]: daemonize: SIGTTOU caught
    Dec 19 11:33:24 MYSERVER /usr/sbin/namcd[7087]: daemonize: SIGTTIN caught
    Dec 19 11:33:24 MYSERVER /usr/sbin/namcd[7087]: daemonize: SIGTSTP caught
    Dec 19 11:33:24 MYSERVER /usr/sbin/namcd[7089]: main: Starting namcd
    Dec 19 11:33:24 MYSERVER /usr/sbin/namcd[7089]: readConfigParameter: Base conetxt = o=MyContext
    Dec 19 11:34:15 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:26 MYSERVER logger: /etc/init.d/xdm: No changes for /etc/X11/xdm/Xservers
    Dec 19 11:35:26 MYSERVER logger: /etc/init.d/xdm: No changes for /etc/X11/xdm/xdm-config
    Dec 19 11:35:26 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:26 MYSERVER smbd[10719]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:26 MYSERVER smbd[10719]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:28 MYSERVER gdm[10748]: WARNING: socket: Address family not supported by protocol
    Dec 19 11:35:30 MYSERVER httpd2-prefork: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:30 MYSERVER httpd2-prefork: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:30 MYSERVER httpd2-prefork: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:30 MYSERVER httpd2-prefork: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:30 MYSERVER httpd2-prefork: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:32 MYSERVER gdm-simple-slave[11367]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:33 MYSERVER dbus-daemon: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:33 MYSERVER gdm-simple-slave[11373]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:35 MYSERVER gdm-simple-slave[11252]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:35 MYSERVER gdm-simple-slave[11252]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:35 MYSERVER pulseaudio[11413]: pid.c: Stale PID file, overwriting.
    Dec 19 11:35:35 MYSERVER pulseaudio[11413]: module.c: module-hal-detect is deprecated: Please use module-udev-detect instead of module-hal-detect!
    Dec 19 11:35:35 MYSERVER gdm-simple-greeter[11405]: GLib-GObject-CRITICAL: g_param_spec_flags: assertion `G_TYPE_IS_FLAGS (flags_type)' failed
    Dec 19 11:35:35 MYSERVER gdm-simple-greeter[11405]: GLib-GObject-CRITICAL: g_object_class_install_property: assertion `G_IS_PARAM_SPEC (pspec)' failed
    Dec 19 11:35:39 MYSERVER [XTCOM]: pam_sm_authenticate in pam_ncl.c (novell-client's pam)is called
    Dec 19 11:35:43 MYSERVER [XTCOM]: inside ncl pam : user name obntained is : [root]
    Dec 19 11:35:43 MYSERVER [XTCOM]: Password is not available to the NCL PAM module. So reprompting for password
    Dec 19 11:35:43 MYSERVER [XTCOM]: WARNING: gdm_session_settings_load: lang = (null)
    Dec 19 11:35:47 MYSERVER [XTCOM]: pam_ncl.c:pam_sm_open_session called
    Dec 19 11:35:47 MYSERVER pam_autoncl[11411]: pam_ncl_autologin authenticate started.
    Dec 19 11:35:47 MYSERVER pam_autoncl[11411]: Auto Login will not continue - disabled for root user
    Dec 19 11:35:47 MYSERVER gdm-session-worker[11411]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 11:35:48 MYSERVER checkproc: checkproc: can not get session id for process 16115!

    /var/log warn
    Dec 19 12:45:01 MYSERVER cron[4116]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:45:10 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:45:58 MYSERVER [XTCOM]: inside ncl pam : user name obntained is : [root]
    Dec 19 12:45:58 MYSERVER [XTCOM]: Password is not available to the NCL PAM module. So reprompting for password
    Dec 19 12:45:58 MYSERVER [XTCOM]: WARNING: gdm_session_settings_load: lang = (null)
    Dec 19 12:46:02 MYSERVER [XTCOM]: pam_ncl.c:pam_sm_open_session called
    Dec 19 12:46:02 MYSERVER pam_autoncl[30073]: pam_ncl_autologin authenticate started.
    Dec 19 12:46:02 MYSERVER pam_autoncl[30073]: Auto Login will not continue - disabled for root user
    Dec 19 12:46:03 MYSERVER gdm-session-worker[30073]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:46:05 MYSERVER checkproc: checkproc: can not get session id for process 11621!
    Dec 19 12:46:06 MYSERVER dbus-daemon: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:46:20 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:46:30 MYSERVER gvfsd-trash: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:46:36 MYSERVER gnome-session[6248]: WARNING: Application 'nautilus.desktop' failed to register before timeout
    Dec 19 12:46:36 MYSERVER pulseaudio[8301]: module.c: module-hal-detect is deprecated: Please use module-udev-detect instead of module-hal-detect!
    Dec 19 12:46:46 MYSERVER gvfsd-burn: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:47:29 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:48:39 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:49:49 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:50:59 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:52:09 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:53:18 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:54:28 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:55:38 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:56:52 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:57:20 MYSERVER sshd[27037]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:58:02 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 12:59:12 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 13:00:01 MYSERVER cron[31277]: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0
    Dec 19 13:00:22 MYSERVER id: nds_nss_GetGroupsbyMember: Failed to init socket, status = 0

    /var/log/boot.msg
    Executing customized settings before starting the Novell eDirectory server...
    Starting Novell eDirectory server...
    A previous instance of ndsd was not shutdown cleanly. Ignoring old pid file.
    done
    Executing customized settings after starting the Novell eDirectory server...
    Novell eDirectory LDAP Server is listening on the TCP port.
    Novell eDirectory LDAP Server is listening on the TLS port.
    <notice -- Dec 19 12:32:19.650430000> 'ndsd start' exits with status 0
    <notice -- Dec 19 12:32:19.651468000> novell-tomcat6 start
    done
    <notice -- Dec 19 12:32:22.32817000> 'novell-tomcat6 start' exits with status 0
    <notice -- Dec 19 12:32:22.33552000> nscd start
    Starting Name Service Cache Daemon
    <notice -- Dec 19 12:32:22.155261000> startproc: execve (/usr/sbin/nscd) [ /usr/sbin/nscd ], [ CONSOLE=/dev/console SELINUX_INIT=YES ROOTFS_FSTYPE=ext3 SHELL=/bin/sh TERM=linux ROOTFS_FSCK=0 crashkernel=256M-:128M LC_ALL=POSIX INIT_VERSION=sysvinit-2.86 REDIRECT=/dev/tty1 COLUMNS=96 PATH=/bin:/sbin:/usr/bin:/usr/sbin vga=0x314 DO_CONFIRM= RUNLEVEL=5 PWD=/ SPLASHCFG=/etc/bootsplash/themes/SLES/config/bootsplash-800x600.cfg PREVLEVEL=N LINES=33 HOME=/ SHLVL=2 splash=silent SPLASH=yes ROOTFS_BLKDEV=/dev/disk/by-id/scsi-3600508e000000000e5dedeb9a7b3cd00-part6 _=/sbin/startproc DAEMON=/usr/sbin/nscd ]
    done
    <notice -- Dec 19 12:32:22.501773000> 'nscd start' exits with status 0
    <notice -- Dec 19 12:32:22.513547000> splash start
    <notice -- Dec 19 12:32:22.538885000> 'splash start' exits with status 0
    <notice -- Dec 19 12:32:22.539884000> namcd start
    Starting NAM Cache Daemon ...
    Waiting for LDAP server to be ready ...
    /usr/bin/namldapprobe: /usr/lib64/libldapsdk.so.0: no version information available (required by /usr/bin/namldapprobe)
    /usr/bin/namldapprobe: /usr/lib64/libldapssl.so.0: no version information available (required by /usr/bin/namldapprobe)
    /opt/novell/eDirectory/lib64/libldapx.so.0: symbol ber_flatten, version NLDAPSDK_VERSION not defined in file libldapsdk.so.0 with link time reference
    ./usr/bin/namldapprobe: /usr/lib64/libldapsdk.so.0: no version information available (required by /usr/bin/namldapprobe)
    /usr/bin/namldapprobe: /usr/lib64/libldapssl.so.0: no version information available (required by /usr/bin/namldapprobe)
    /opt/novell/eDirectory/lib64/libldapx.so.0: symbol ber_flatten, version NLDAPSDK_VERSION not defined in file libldapsdk.so.0 with link time reference
    ./usr/bin/namldapprobe: /usr/lib64/libldapsdk.so.0: no version information available (required by /usr/bin/namldapprobe)

    As result the namcd don't start. The server works, but I fixed this problem before install the next groupwise version. The replica is for the moment read/write. The master is on Netware 6.5.8. I want to change the master to the Sles machine, because of the old netware servers end.
    How can I solve the problem?

    Thanks in advance for your answers.

    Best regards.

    Dirk Emmermacher
    Last edited by Emmermacher; 19-Dec-2013 at 01:14 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •