Is there any word on a new version of the remote management viewer (or any browser plugin) that will work with the latest firefox ESR ? (24.2.0)
It is getting harder and harder to block browser updates from installing without user intervention .. even outside of that it is also bad practice to keep using outdated browsers from a security perspective. The internet is getting to be a more nasty place by the day almost.

Personally I feel that the ESR version should be supported within 1 or 2 months after their release, but I am assuming there are reasons that this is not the case.