Performing workstation builds using the ENGL Imaging Toolkit build process (v8.01)

We have one workstation where the 'zac reg' failes after 20mins with the
"Exception: Failed to read from an IPC Port: The pipe has been ended.

From the wstn zmd-messages you get
Registration successful, response was '' (i.e. null)

and in the server services-messages there are iterative " [DEBUG] [13/01/14 16:05:39] [] [Registration Web Service] [104] [] [refreshing ignored list of reconcile attributes] [] []
[DEBUG] [13/01/14 16:05:39] [] [Registration Web Service] [104] [] [registerDevice complete, time: 94ms, code: 0, device: 7d8390f3945b5f4ead1cf844f25fcf6e, thread: 104] [] []"

I see this on whichever primary server I point the device at (have tried two)

I have tried clearing zisd, I have tried updating and resetting BIOS, I have tried a replacement hard disk.
I have tried forcing registration to a different primary (same result)

I am wondering whether there is a 'bad' record in the database relating to this device, however I have performed ZCM queies on serial number, etc. and can't see anything...

Has anyone seen this type of error? or can suggest additional troubleshooting?