Our ZMM server is on version 2.8.2
Play Store App is version
https://zmmupdate.novell.com/apps version is

When I try to enroll a new device, I am getting "Invalid credentials supplied." I am trying to enroll from the version downloaded from the zmmupdate page... which appears to be an outdated version. I have tried from multiple types of Android devices and several different users, and get the same results when using that version. If this is a known issue with out of date versions, could someone at Novell please update the zmmupdate page version to the latest so that I can once again start enrolling devices? I would prefer not having to set up a play store account for all these devices just so that I can get the latest app...