On 8 of our 9 ZCM servers, the upgrade from 11.2.3aMU1 to 11.2.4 succeeded without incident. However. I can't get one server to complete. It is the "sister server" (identical hardware, similar history) of another server which upgraded with no problems.

In ZCC, the status for the update on the problem server is "Update Completed with Errors". The info from Status reads: "There was an error while installing package [/bin/rpm -U --verbose /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks-zmgpxeclientfiles-11.2.4- 45040.i586.rpm]. RPM return code: 2. Check the system-update.log on the device for details."

When I look in the system-update.log I find these entries:

DEBUG;;;Launching rpm command with parameter: [/bin/rpm -U --verbose /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks-zmgpxeclientfiles-11.2.4- 45040.i586.rpm]
DEBUG;;;return code : 2
DEBUG;;;Checking package /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks- zmgpxeclientfiles-11.2.4-45040.i586.rpm DEBUG;;;Executing query: [/bin/rpm, -qp, /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks-zmgpxeclientfiles-11.2.4- 45040.i586.rpm, --queryformat, @%{version}.%{release}@]
DEBUG;;;Output: @ DEBUG;;;Executing query: [/bin/rpm, -qp, /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks-zmgpxeclientfiles-11.2.4- 45040.i586.rpm, --queryformat, @%{name}@]
DEBUG;;;Output: @novell-zenworks-zmgpxeclientfiles@
DEBUG;;;Executing query: [/bin/rpm, -q, novell-zenworks-zmgpxeclientfiles, --queryformat, @%{version}.%{release}@] DEBUG;;;Output: @ DEBUG;;;Package version: installedVersion:
DEBUG;;;Could not find an installed version greater than or equal to package version DEBUG;;;rpm command failed...will retry

and this repeats several times, I think five. Following the last retry it the log has this entry:

ERROR;RPM_INSTALL_ERROR;[/bin/rpm -U --verbose /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks-zmgpxeclientfiles-11.2.4- 45040.i586.rpm],2;null
DEBUG;;;An error occured during command execution...details should have already been logged

If I manually run the command:
/bin/rpm -U --verbose /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks-zmgpxeclientfiles-11.2.4-45040.i586.rpm
on the server it responds with:
Preparing packages for installation... package novell-zenworks-zmgpxeclientfiles-11.2.4-45040 is already installed
And if I run:
/bin/rpm -qp /var/opt/novell/zenworks/zmd/cache/ZenCache/1a41870360344a7f91513db55dbdc7aa/novell-zenworks-zmgpxeclientfiles-11.2.4-45040.i586.rpm --queryformat @%{version}.%{release}@
it responds with:

I have cleared the cache and refreshed and reassigned the update three times, and the result is always the same, just as noted above.

Also as noted I have another server, identical hardware and software, same OS (SLES 10.4), and it upgraded with no problems.

I ran ZDC on the problem machine. There were no problems with the database (2 mismatch views), no problems in the Content Verifier, and the file verifier showed many missing files and inconsistent files. I can't get too excited about that news, since the ZDC version is 11.2.3a and the server is running 11.2.3a MU1, so of course many files have been updated compared to the 11.2.3a baseline. Since all my other 11.2.3a MU1 servers successfully upgraded to 11.2.4, I can't make a better baseline file.

Anybody here that can point me in the right direction for my next step?