I'm working to set up Kanaka to mount a volume from a server that we've been using to serve Windows machines for quite a while.

As far as AFP/CIFS goes, the volume works just fine if it's manually mounted. However, Kanaka shows the following error in Storage Resources, next to the entry for this volume:
Code:
Unable to read attribute value; Result = 163.
I moved to verbose logging, and checked the log files from Kanaka after a Storage Rebuild, and saw the following:
Code:
01 2014-03-05 15:19:37 -18000 3 0006 6754 7fe125466700 MPM: Failed to get volume FDN for server SERVER, volume DATA: 163
01 2014-03-05 15:19:37 -18000 3 0006 6754 7fe125466700 MPM: Unable to retrieve volume name for path \\SERVER\DATA: 163
...
01 2014-03-06 08:48:02 -18000 7 8008 6754 7fe11e458700 CCStorageResources::WorkerThreadFunction() - Volume "DATA" on server "CN=SERVER.OU=DEPT.O=COMPANY" is a known existing volume.
01 2014-03-06 08:48:02 -18000 5 8008 6754 7fe11e458700 CCStorageResources::WorkerThreadFunction() - Volume "DATA" on server "CN=SERVER.OU=DEPT.O=COMPANY" does not have a volume item associated with it.
Then, I checked through iManager, and made sure that all the AFP/CIFS settings and Volume listings were identical to the other servers that are already working. I checked through the "Other" tab for attributes that other servers/volume objects had that this one didn't, and after making everything match, the log entries changed to look more like this:
Code:
01 2014-03-06 09:10:47 -18000 7 8008 6754 7fe118c4d700 CCStorageResources::WorkerThreadFunction() - Volume "DATA" on server "CN=SERVER.OU=DEPT.O=COMPANY" is a known existing volume.
01 2014-03-06 09:10:47 -18000 7 8008 6754 7fe118c4d700 CCStorageResources::WorkerThreadFunction() - Volume "DATA" on server "CN=SERVER.OU=DEPT.O=COMPANY" has mounted volume information that needs to be added to the volume item "CN=SERVER_DATA.OU=DEPT.O=COMPANY".
But this part was still there:
Code:
01 2014-03-06 09:10:35 -18000 3 0006 6754 7fe124464700 MPM: Failed to get volume FDN for server SERVER, volume DATA: 163
01 2014-03-06 09:10:35 -18000 3 0006 6754 7fe124464700 MPM: Unable to retrieve volume name for path \\SERVER\DATA: 163
The original error is still there in Storage Resources:
Code:
Unable to read attribute value; Result = 163.
Any Ideas?

Novell Open Enterprise Server 11 (x86_64)
VERSION = 11
PATCHLEVEL = 0