The problem I have the hardest time with ZCM is laptops off network. I'm on 11.3 have firewall ports inbound open for 80 and 443 and 2645 TCP. Some users get the Unable to log into network because the login credentials or server certificate is incorrect, here is some of the log from a user trying to login to ZCM.


[DEBUG] [03/27/2014 09:31:13.239] [1504] [ZenworksWindowsService] [51] [] [RemotingService] [] [ZENSetSessionAuthenticationState entered] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:31:13.239] [1504] [ZenworksWindowsService] [51] [] [RemotingService] [] [ZENSetSessionAuthenticationState returning SUCCESS] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:31:13.239] [1504] [ZenworksWindowsService] [51] [] [AuditLogger] [] [GetAuditXMLBlob returned: <UserData><zOps>UserLogin</zOps><zusername>DCHStech</zusername><status>Failed</status><errcode>1</errcode><realm>DICKSON_COUNTY</realm><localuser>DCHStech</localuser></UserData>] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:31:13.239] [1504] [ZenworksWindowsService] [51] [] [RemotingService] [] [ZENLogin returning FAILURE] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:31:27.527] [1504] [ZenworksWindowsService] [60] [] [AppLocalState] [] [Total time for serializing app state files is 0 ms] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:31:33.127] [1504] [ZenworksWindowsService] [24] [] [SessionManager] [] [GetSession is returning null for 9502307] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:48.959] [1504] [ZenworksWindowsService] [37] [] [ExtMsgProc] [] [ProcessMessages - wakeup] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:31:13.239] [1504] [ZenworksWindowsService] [51] [] [ZenworksWindowsService : AuditEventLogger] [] [Audit event not logged, IsShuttingDown False& IsDisabled True] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:48.959] [1504] [ZenworksWindowsService] [37] [] [ExtMsgProc] [] [ProcessMessages - sleeping] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [Scheduler -- === EventID = registrationEvent:updatePrimaryUserInfo -- Scheduled to fire at: Thursday, March 27, 2014 9:32:50 AM] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [Scheduler -- === EventID = registrationEvent:updatePrimaryUserInfo -- Fired at: Thursday, March 27, 2014 9:32:50 AM] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [EventManager -- EventTrigger for registrationEvent:updatePrimaryUserInfo has been called.] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [EventManager -- EventTrigger for registrationEvent:updatePrimaryUserInfo has been called.] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [Scheduler -- --- TESS Fire Schedule ====== schedule with event ID: registrationEvent:updatePrimaryUserInfo at time: Thu, 27 Mar 2014 09:32:50 GMT] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [Scheduler -- === EventID = registrationEvent:updatePrimaryUserInfo -- Expires at: Monday, January 01, 0001 12:00:00 AM] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [Scheduler -- === EventID = registrationEvent:updatePrimaryUserInfo -- Next due time: Thursday, March 27, 2014 9:42:50 AM] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [14] [] [Novell.Zenworks.Tess] [] [Scheduler -- === EventID = registrationEvent:updatePrimaryUserInfo -- Scheduled to fire at: Thursday, March 27, 2014 9:42:50 AM] [] [] [] [ZENworks Agent]
[DEBUG] [03/27/2014 09:32:50.535] [1504] [ZenworksWindowsService] [64] [] [ZenCache] [] [(Thread 64) PutObject(registrationrimaryUserInfo, UserContext{_LocalId=SYSTEM; _RemoteId=ae18bfe39f335c4eb39ee2a3e0cf1d0a}) called] [] [] [] [ZENworks Agent]

We are still a e-dir company, so the computer has client 32 on it and the user does workstation only when off network then logins into windows an gets the ZCM login. They give it the same user name and password and get (Unable to log into network because the login credentials or server certificate is incorrect) so they have to cancel it and get no user bundles or user grouppolicy. Could this have something to do with the client not passing something to ZCM because the user is doing workstation only. When brought back to corporate network works fine sometimes have to zac cc the machine.