I've been getting reports of issues opening certain image files -- image explorer closes immediately after starting to load the .zmg file.

Contents of the zmgexp.log:

Exception in thread "main" java.lang.OutOfMemoryError: Java heap space
at com.novell.ImgExplorer.FileHeader.readFromFile(Fil eHeader.java:27)
at com.novell.ImgExplorer.Main.loadImageFile(Main.jav a:439)
at com.novell.ImgExplorer.Main.openFile(Main.java:354 )
at com.novell.ImgExplorer.ImgExplorerToolbar$2.widget Selected(ImgExplorerToolbar.java:65)
at org.eclipse.swt.widgets.TypedListener.handleEvent( Unknown Source)
at org.eclipse.swt.widgets.EventTable.sendEvent(Unkno wn Source)
at org.eclipse.swt.widgets.Widget.sendEvent(Unknown Source)
at org.eclipse.swt.widgets.Display.runDeferredEvents( Unknown Source)
at org.eclipse.swt.widgets.Display.readAndDispatch(Un known Source)
at com.novell.ImgExplorer.Main.run(Main.java:110)
at com.novell.ImgExplorer.Main.main(Main.java:228)

I've tried adjusting the memory heap parameters with -Xms and -Xmx -- no difference.

The image file I'm currently testing with was captured with ZCM 11.2.3 (non-a) with the -legacyntfs switch.

I've tried a number of versions of zmgexp (, and 11.2.4-45040) -- they all behave the same. This is on 64-bit Windows 7 Enterprise SP1 -- both JRE 32-bit and 64-bit installed. I've tried capturing the 32-bit JRE in %PATH% with no change.

Tried on 32-bit XP Pro SP1 -- same behaviour.

I captured a test image myself and in the same manner -- same behaviour. Capturing again without the -legacyntfs switch to see if that's helping or hindering.

Suggestions? I've seen suggestions to use the ZCM 7 image explorer, but I'm not sure that's wise.