Results 1 to 2 of 2

Thread: Problems with wildcard certificate - actually solved already

Threaded View

  1. #1
    Join Date
    Apr 2008
    Greve, Denmark

    Problems with wildcard certificate - actually solved already

    Just making a mental note, and while doing so, I hope this will benefit others.

    I've just gotten a new wildcard certificate, and of course there is an intermediate certificate with it.
    So after trying to get this working, I finally succeeded.

    First step: conversion

    Convert both the received certificate and the intermediate to PEM format:

    openssl x509 -in intermediate.crt -out intermediate.der -outform DER
    openssl x509 -in intermediate.der -inform DER -out intermediate.pem -outform PEM
    And repeat that for the server certificate.

    Then combine the KEY, server and intermediate to one file.

    cat private.key server.pem intermediate.pem > combined.pem
    The order of these are very important, for me the logical was to put the intermediate before the server, as I then thought the system could understand the private, but that was wrong.
    The order HAS to be private.key server.pem intermediate.pem

    And copy that to the right place:

    cp combined.pem /var/lib/datasync/device/mobility.pem
    That made it work here...
    Last edited by fribert; 03-Jun-2014 at 02:40 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts