Good afternoon,
Customer is seeing a dependency issue when trying to patch through ZCM, please see the following:

finished testing the patching on the non-zcm servers with no issues. The steps followed were:
1. associate just the sles10sp4 (non ltss) channel
2. run rug up
3. associate just the sles10sp4 ltss and oes2sp3 channels
4. run rug up

On the ZCM server, attempting to do the same thing:
1. associate just the sles10sp4 (non ltss) channel -- ran fine
2. run zac up --> ran fine, no errors
3. associate just the sles10sp4 ltss and oes2sp3 channels
4. run zac up --> get attached dependency errors. Have tried a number of things to get around issue

Expected that both servers would have behaved the same, cannot get past these dependency errors on the ZCM server. The other server running RUG did not have any errors. Please see the copied portions of the log txt file.

Wed Jul 23 15:46:54 2014 : INFO : Read the transactions from DB.
Wed Jul 23 15:46:54 2014 : INFO : Solving for install/removal.
Wed Jul 23 15:46:54 2014 : DEBUG : Going to solve.
Wed Jul 23 15:46:54 2014 : DEBUG : Finished solving.
Wed Jul 23 15:46:54 2014 : ERROR : Dependency resolution failed with 14 problems
Wed Jul 23 15:46:54 2014 : ERROR : RPM_NOTHING_PROVIDES_DEP: cups needed by firefox-gtk2-2.18.9-0.9.2.x86_64
Wed Jul 23 15:46:54 2014 : ERROR : RPM_NOTHING_PROVIDES_DEP: cups needed by firefox-gtk2-2.18.9-0.9.2.x86_64
Wed Jul 23 15:46:54 2014 : ERROR : RPM_NOTHING_PROVIDES_DEP: cups needed by firefox-gtk2-2.18.9-0.9.2.x86_64
Wed Jul 23 15:46:54 2014 : ERROR : PACKAGE_REQUIRES: firefox-gtk2-i386 needed by MozillaFirefox-24.6.0esr-0.5.4.i586
Wed Jul 23 15:46:54 2014 : ERROR : RPM_NOTHING_PROVIDES_DEP: cups needed by firefox-gtk2-2.18.9-0.9.2.x86_64
Wed Jul 23 15:46:54 2014 : ERROR : RPM_NOTHING_PROVIDES_DEP: cups needed by firefox-gtk2-2.18.9-0.9.2.x86_64
Wed Jul 23 15:46:54 2014 : ERROR : PACKAGE_REQUIRES: 'MozillaFirefox = 24.6.0esr' needed by MozillaFirefox-translations
-24.6.0esr-0.5.4.i586
Wed Jul 23 15:46:54 2014 : INFO : Finished resolve-dependencies /var/opt/novell/zenworks/lib/pkgdb.db

~
~

/var/log/zmd-setbackend.log
Are there any switch settings to bypass the dependency error? These servers are still running SLES 10 SP4 and OES2 SP 3. If there is any additional information needed/requested please let me know.

Thank you,
DS