While working through this, I solved the issue, but decided to post this anyway as it may help others to find these sorts of errors.

I'm working on migrating from NetWare 6.5sp8 to OES11sp2. Client has Shoretel VOIP phones. Existing NetWare-based DHCP has no problem. Option 156 has been configured to give out the required text information that Shoretel phones require.

Problem is that I could not get the OES11 DHCP to run with that option. Nor could I migrate the existing option over - the Migration Tool (in OES11) says it successfully migrates DHCP, but I cannot start the dhcpd daemon. Error is that it failed, and in the rc.dhcpd.log file I see an error:

LDAP Line 26: unknown option dhcp.Shoretel_Boot.
LDAP Line 26: unexpected end of file
LDAP: cannot parse dhcpService entry 'cn=newdhcpservice,o=LIBRARY'
Configuration file errors encountered -- exiting

If I look in the file (created when LDAP reads DHCP config from eDirectory apparently) dhcp-ldap-startup.log I can see the problem entry at line 26:

option Shoretel_Boot "FTPSERVERS=,COUNTRY=1,LANGUAGE=1,L AYER default-lease-time 259200 ;

This option does NOT show up in the newdhcpservice option when I look at it in ConsoleOne, or DSBROWSE, or DNS/DHCP Management Console.

This option DOES show up in the DNS/DHCPManagement Console if I look at the DHCP (NetWare) tab and look at Other DHCP Options for some of the configured subnets, but it actually has different text from the above, specifically:

Note that it does not have a " character anywhere in the entry. This option is configured as a Global DHCP text option.

Novell TID 7009464 mentions the issue, though not for Option 156. In that TID there is this:
"Situation #2
Migrate a working DHCP server with DHCP options that are of type "Text" to an OES server.
Load the DHCP server service... it fails to load and gives similar errors to the ones listed above."

Under resolution the TID says to delete and recreate the dhcp service object without the text option and it will load. That doesn't work for me as I still get an LDAP error pointing to the Shoretel_Boot unknown option. (I dare not try deleting it from the NetWare DHCP config and risk breaking the client's phone system).

One of the options in the TID to fix this is to re-enter the data using the DNS/DHCP Management Console - but that didn't work.

Here is the answer:
First, the log files are misleading. The error message points to not being able to read the newdhcpservice object entry - but the problem was elsewhere. In fact the problem showed up in the logs even when there were no option 156 entries at all in any object inside the newdhcpservice or the newdhcpservice object itself. The problem existed in the NetWare configuration of the object for one of the dhcp subnets.

Specifically, there was an illegal character in the text entry for option 156 - the # character was in there, like this:


If you look at the error log entry for syntax error you can see that the option 156 text stopped at the # symbol, and then default-lease-time was appended to the end.

Removing the # symbol got things working.

Craig Johnson
(former Novell partner / sysop)