I'm doing an upgrade from GW2012 sp1 to gw2014
We also have Datasync 1.2.5

GW2014 says update to GMS 2.0 before upgrading to gw 2014
GMS 2.0 requires GW2012 sp2

Do I need to update GW2012 sp1 to GW2012 SP2 (as GMS2.0 reqiures) before
I can upgrade to GW2014


Can I stay on GW2012 sp1, upgrade to GMS2.0 and after that to GW2014
skipping the GW2012 SP2 step ?