I am currently struggling to get autodiscover to work across our 4 GMS 2.0.1 servers, one for staff and 3 for students.
Everyones email address has the format user@college.ac.uk

I have SRV DNS records setup as follows.

Record Key Type Value
_autodiscover._tcp SRV 0 0 443 datasyncstud1.college.ac.uk
_autodiscover._tcp SRV 0 0 443 datasyncstud2.college.ac.uk
_autodiscover._tcp SRV 0 0 443 datasyncstud3.college.ac.uk
_autodiscover._tcp SRV 0 0 443 datasyncstf.college.ac.uk
_ngms._tcp.datasyncstf SRV 0 0 443 datasyncstf.college.ac.uk
_ngms._tcp.datasyncstud1 SRV 0 0 443 datasyncstud1.college.ac.uk
_ngms._tcp.datasyncstud2 SRV 0 0 443 datasyncstud2.college.ac.uk
_ngms._tcp.datasyncstud3 SRV 0 0 443 datasyncstud3.college.ac.uk

All the servers referenced there also have A records correctly setup.
Using https://testconnectivity.microsoft.com I have determined if I only have an autodiscover record for 1 GMS server and use the credentials for a user on that server in the Connectivity Analyzer, it works fine.
So my setup is ok connectivity wise, firewalls etc must be setup right but how do I setup DNS to make this work with multiple GMS servers. Using one is not an option as we have over 3000 users, using a different domain name for each server is also not an option as it will cause massive confusion, ie. user@server1.college.ac.uk
The documentation here https://www.novell.com/documentation...uide_admin.pdf seems rather vague in the multiple server config part.

Anyone have any ideas?

Thanks

Dan