I just updated 1 of our 2 DSFW servers from OES10sp3 to OES11sp2 and after booting the DSFW provisioning pops up.
The provisioning however can't log in to the DSFW for some reason:

2014-10-08 16:32:24,823 INFO - Authentication :isUpgraded is true
2014-10-08 16:32:27,392 INFO - Authentication :upgrade_to: oes11sp2 upgrade : YES
2014-10-08 16:32:36,725 INFO - Authentication :Retrying Connection.....
2014-10-08 16:32:36,726 INFO - Authentication :attempting to connect to source with parameters
2014-10-08 16:32:36,784 INFO - Provisioning Utils :Got the IP Address -
2014-10-08 16:32:36,785 INFO - Authentication :Copy - copied certificate to /opt/novell/xad/plugin/conf/TargetCert.der
2014-10-08 16:32:36,786 INFO - Authentication :keytool delete - command to delete source server's certificate
2014-10-08 16:32:37,388 INFO - Authentication :keytool delete - alias exists in the Keytool - true
2014-10-08 16:32:37,388 INFO - Authentication :keytool import - command to store target server's certificate
2014-10-08 16:32:38,054 INFO - Authentication :Authenticating to the Target Server(secure)
2014-10-08 16:32:39,806 ERROR - Provisioning Framework :Authentication :Domain Administrator authentication failed, either the password supplied is incorrect or password set during YaST configuration failed.

Can't find anything about this and the PW is correct. Also tried changing the PW and that did not change anything.
I did notice it tries to authenticate with an eDir context instead of a domain context ? Not sure if this is normal. is the IP of the machine itself.

The primary server is still running the upgrade so not sure how that will go yet.