Please review TID 7015805 and patch your systems against the POODLE weakness.