I have installed GWMS on a new system and am trying to get my Galaxy S5 (Android) to connect to it. When trying to set up Active Sync, I'm getting "You entered an incorrect server address or the server requires a protocol version that Email does not support"

Assuming the GWMS itself is ok (how can I test that?), what does this error mean? I note the S5 is not on the list of devices, but says the S4 is. The instructions for setting that up suggest I need to fill in Domain info and elsewhere it says GWMS does not require that (since we're not using Exchange).

I'm confused: suggestions anyone?