We are using GMS 2.0 and synchronizing with HTC One M8 phones from Verizon.

Everything works fine for a while after the account is created on the phone.
After some time, from a day to two months or more, the user will try to get
their email and will get a message telling them they need to "Activate
Device Administrator". It says that their Exchange server administrator
requires that they accept the security policy in order to continue
synchronizing. In order to get email, they must select accept. Once they
have done this, they are no longer able to download attachments of any size
whereas before they accept it they are able to get up to 500KB attachments
(default). When they try to get an attachment, they are told that Exchange
server policy does not permit this. No such policy is in effect in GMS.

This has affected most of our fleet. There are a handful of phones that have
never received this message and are able to retrieve attachments without
issue. I have no idea what triggers it. Some people get it very shortly
after I add the account, others can go weeks or months before getting the

I have located under Settings > Security > Device Administrators on the
phone where I can disable it, but it will delete the account from the phone
if I do. Deleting the account from the phone will clear the problem until
the message pops up again.

I have found a workaround, but it is less than ideal. I can tell the mail
account to automatically download attachments smaller than 500KB when it
gets the email. This somehow circumvents the incorrect Exchange Server

Has anyone else encountered this or know of a way to fix it?