I have the exact issue as reported by another user on this forum in October but I did not see where it was ever resolved. I am trying to deploy to a Mac with OS X Version 10.9.4. I have Java 8 Update 40 installed but every time I try to install the agent I get the following: "Cannot continue - JRE version 1.6 required. Exiting with error code 235." Can someone help me get past this? We are using Zenworks 11.2.4. I tried the apple links from the October thread but they do not work because it is an outdated version of Java at this point.