I have upgraded my workstation from OpenSUse 11.4 to 12.2 x64 and this went
smoothly except that Designer 4.0.2 no longer runs. I admit that I didn't
notice this was not a supported OS so that was my mistake. However I don't
think it's far off from running and I'm just seeing if any one else can
suggest a fix or debugging, pending, hopefully better support on a
soon-to-come release.

When I start Designer it gets as far as displaying my last project, but then
it just exits without a message. If I start it from a prompt I get this set
of messages:

In constructor if com.novell.soa.logging.impl.log4j.Log4jManager
The program 'Designer' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
(Details: serial 27555 error_code 8 request_code 152 minor_code 4)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

I can't find any log errors but I may be looking in the wrong place.

I thought that it was perhaps failing during an attempt to check for
updates, so I installed the 32 bit xulrunner package and added this line to
my Designer.ini as per the readme

I tried reinstalling, but this failed to fix the start up, despite saying it
was 100% successful

I have seen this thread:

I have these possibly relevant rpms installed and the latest patches all

The requirements talk about
libgthread-2_0-0-32bit-2.17.2+2.17.3+20080708+r7171-3.1.x86_64.rpm compat
but a Google only finds me an 11.4 version. Attempting to install this
displays a file clash with libgthread-2_0-0-32bit-2.32.4-4.8.1.x86_64 which
I don't want to uninstall for dependency reasons.

Maybe this is fakeable by adding a symlink somewhere?

Oh for an rpm installer that would at least tell me what I need!