Hi all - long time reader, first time poster. I have a seemingly easy
issue to resolve that I just can't figure out. I am trying to configure
a remote loader on a DC and I keep getting the following error:

================================================== =======
DirXML: [03/23/12 10:44:52.90]: Loader: Verifying command port...
DirXML: [03/23/12 10:44:53.99]: Loader: Verifying driver can be
loaded...
DirXML: [03/23/12 10:44:53.99]: ADDriver: Driver::destroy
DirXML: [03/23/12 10:44:53.99]: ADDriver: Driver::~Driver()
DirXML: [03/23/12 10:44:53.99]: Loader: Initializing SSL encryption...
DirXML: [03/23/12 10:44:56.04]: Loader: Waiting for DirXML to connect
on 'TCP server socket, port 8090, address localhost, using SSL'...
DirXML: [03/23/12 10:45:05.54]: Loader: Received 'handshake' document
DirXML: [03/23/12 10:45:05.54]: Loader: XML Document:
DirXML: [03/23/12 10:45:05.54]: <handshake version="1.0">
<password><!-- content suppressed --></password>
</handshake>
DirXML: [03/23/12 10:45:06.23]:
DirXML Log Event -------------------
Thread = Connection Monitor
Level = warning
Message = Handshake timeout: closing connection
DirXML: [03/23/12 10:45:06.23]:
DirXML Log Event -------------------
Thread = Subscriber Channel
Level = error
Message = Authentication handshake failed: No response to handshake
document
DirXML: [03/23/12 10:45:06.23]:
DirXML Log Event -------------------
Thread = Connection Receiver
Level = warning
Message = SSL protocol failure: error:1408F10B:SSL
routines:SSL3_GET_RECORD:wrong version number
DirXML: [03/23/12 10:45:06.35]: Loader: Waiting for DirXML to connect
on 'TCP server socket, port 8090, address localhost, using SSL'...
================================================== =======


I've spent a great deal of time researching the issue & from what I can
tell everything is correct but I keep getting this error. What I have
done so far:

*** Exported the Self Signed Certificate in base64 format from the CA
*** Created a certificate for the AD Driver to use in my metadirectory
*** Configured my Remote Loader with the following parameters
Driver = C:\Novell\RemoteLoader\ADDriver.dll
Config File = C:\Novell\RemoteLoader\SSLADRemoteLoader-Config.txt
Command Port = 8093
Connection Port = 8090
Address = All
Trace Level = 3
Trace File = C:\Novell\LogFiles\SSLADRemoteLoader-Trace.log
Trace File Size = 10
Trusted Root File =
C:\Novell\Certificates\TESTIDENT-CA-SelfSignedCert.b64
*** Confirmed the Remote Loader Password matches (reset password &
manually set)
*** Confirmed the Driver Object Password matches (reset password &
manually set)
*** Configured the AD Driver to use SSL
*** Configured the Remote Loader Connection parameters with the
following: hostname=10.16.132.7 port=8090 kmo='LoaderTESTRWD13'

I have followed the instructions here and on various threads.
http://www.novell.com/support/php/se...rnalId=7003300





What am I missing? What more troubleshooting can I do? This is
getting extremely frustrating & I am at my witts end with this. Thanks
in advance for any help anyone may be able to provide.


--
EvilDobe
------------------------------------------------------------------------
EvilDobe's Profile: http://forums.novell.com/member.php?userid=103503
View this thread: http://forums.novell.com/showthread.php?t=453841