I dont know the best place for this question, on eDir or IDM forum ? but
help is needed

I have en eDirectory 8.7.3 , and IDM 2.0.2 ( old versions ) on Windows
2003, I have to move all that to SLES 11 SP2 and upgrade to eDir 8.8.7
and IDM 4.0.2

The plan is to install eDir 8.8.7 to SLES 11 SP2 and add it to the
replica ring ( I am very used to this task so the issue is not here )

I have no issue with eDirectory part

But regarding installing IDM 4.0.2 on SLES 11 SP2, I have a question
about schema, as I have already IDM 2.0.2 in the replica ring,
installing IDM 4.0.2 on SLES 11 SP2 will extend the directory schema (
adding dirXML classes and attributes to suite IDM 4.0.2), the new schema
will be then replicated with the "eDir 8.7.3 and IDM 2.0.2" schema ! so
I am asking the question if that will not cause problems with IDM 2.0.2
as the schema was updated to suite IDM 2.0.2

The question could be summerized as follow " is IDM 4.0.2 schema
backward compatibility with IDM 2.0.2 exisists?"

if it's incompatible , I think in place upgrade (IDM 2.0.2 --> IDM 3.5)
will be necessary, what do you think ?


iammi's Profile: https://forums.netiq.com/member.php?userid=382
View this thread: https://forums.netiq.com/showthread.php?t=46173