IDM 4.0.2 Standard on W2K8R2. Delimited Text Driver.

So I have a mostly working DTM driver, but today I did some checking and
tried to modify an individual attribute by editing my test input file. I
started with Surname which failed on a -608, I spent some hours tearing
my hair out over that, then I tried this:

[03/15/13 17:30:01.779]:HR Imports PT:
<nds dtdversion="4.0" ndsversion="8.x">
<source>
<product edition="Standard" version="4.0.2.0">DirXML</product>
<contact>Novell, Inc.</contact>
</source>
<input>
<modify class-name="User"
*dest-dn="\LIRR_TEST_AUTH\LIRR\Users\llmende"* dest-
entry-id="34200" from-merge="true" src-dn=" ">
<modify-attr attr-name="Title">
<remove-value>
<value timestamp="1362691333#13" type="string">Asst Dir Claims
&amp; I
nvstgtns</value>
</remove-value>
</modify-attr>
<modify-attr attr-name="Title">
<add-value>
<value type="string">Asst Dir Claims and Invstgtns</value>
</add-value>
</modify-attr>
<operation-data/>
</modify>
</input>
</nds>
[03/15/13 17:30:01.781]:HR Imports PT:Filtering out notification-only
attributes
..
[03/15/13 17:30:01.781]:HR Imports PT:Pumping XDS to eDirectory.
[03/15/13 17:30:01.781]:HR Imports PT:Performing operation modify for
\LIRR_TEST
_AUTH\LIRR\Users\llmende.
[03/15/13 17:30:01.796]:HR Imports PT:--JCLNT--
\LIRR_TEST_AUTH\LIRR\Drivers\HR
Imports - Publisher : Duplicating : context = 315424852, tempContext =
315424882
[03/15/13 17:30:01.797]:HR Imports PT:Modifying entry
\LIRR_TEST_AUTH\LIRR\Users
\llmende.
[03/15/13 17:30:01.799]:HR Imports PT:--JCLNT--
\LIRR_TEST_AUTH\LIRR\Drivers\HR
Imports - Publisher : Calling free on tempContext = 315424882
[03/15/13 17:30:01.838]:HR Imports PT:
DirXML Log Event -------------------
Driver: \LIRR_TEST_AUTH\LIRR\Drivers\HR Imports
Channel: Publisher
Object: (\LIRR_TEST_AUTH\LIRR\Users\llmende)
Status: Error
Message: Code(-9010) An exception occurred:
novell.jclient.JCException: mo
difyEntry -608 ERR_ILLEGAL_ATTRIBUTE
[03/15/13 17:30:01.845]:HR Imports PT:Missing valid association or
dest-dn.

But there is a dest-dn (see *bold* above) and what could be wrong with
changing the Title attribute on a User object? The driver is admin
equivilent so it's not security. Maybe it's because it's Friday and I
want to go home, but I just can't see this...

As always, help is appreciated.
Rob


--
rrawson
------------------------------------------------------------------------
rrawson's Profile: https://forums.netiq.com/member.php?userid=403
View this thread: https://forums.netiq.com/showthread.php?t=47101