So, I am attempting to upgrade an IDM solution from 4.0.1 to 4.0.2. It
is all running on Windows. First, I attempted to do an actual upgrade of
the RBPM module, but that resulted in the JBoss service, which is in
4.0.2 and not 4.0.1, was somehow corrupted and was missing it's
configuration files(wrapper.conf). I was unable to solve the problem, so
I decided to do a fresh Windows Server 2008 R2, since that is what we
are actually going to do when the system goes into production. So, now
I've got a fresh Windows Server 2008 R2, all updates installed, service
pack 1 aswell. Now, with the IDM 4.0.2 Windows media mounted, I run the
JBossProsgreSQL.exe file, to install the PostgreSQL database and the
JBoss server. I leave everything as default. When it is about halfway
through, this happens:


Pressing no quits the installer, pressing yes, and I get this:


Pressing ok and I get:


So it seems like it is unable to install the PostgreSQL database for
some reason. I have disabled the Windows firewall, just to see if it had
any effect. I run the installation as Administrator.

The JBossPostgreSQL_InstallLog has no errors, but two warnings:

Copy File: Destination:
Additional Notes: WARNING - Source
C:\novell\idm\Postgres\data\pg_hba.conf does not exist.


Copy File: Destination:
Additional Notes: WARNING - Source
C:\novell\idm\Postgres\data\pg_hba.conf.psql does not exist.

If I take a look, the pg_hba.conf file is actually there. A google on
these errors gives only 1 IDM related result and the post has no
replies. I am not sure this is actually what cause the PostgreSQL
install to fail.

Any ideas on what is going on?

Thanks in advance,


jacmarpet's Profile: https://forums.netiq.com/member.php?userid=415
View this thread: https://forums.netiq.com/showthread.php?t=47947