We have a new IDM 4.0.2 AE environment that we are trying to provision
Exchange 2013 mailboxes in.

We created a new IDM 4 Active Directory driver. We installed the IDM
PowerShell Service. We configured the service to run as a service
account in the AD domain. We validated the account permissions by
executing PowerShell commands direct from the PowerShell client on the
server where the IDM service is installed.

When executing a basic Enable-Mailbox command we are getting the
following error:

"[07/30/14 12:17:17.327]:Exchange 2013 ST:
DirXML Log Event -------------------
\SEMPRA-IDV-QA-TREE\Sempra-IDV\Services\IDM\DriverSet\Exchange 2013
Channel: Subscriber
Object: \SEMPRA-IDV-QA-TREE\Sempra-IDV\Users\Active\799402
Status: Error
Message: Error completing powershell command. ERROR: The term
'Enable-Mailbox' is not recognized as the name of a cmdlet, function,
script file, or operable program. Check the spelling of the name, or if
a path was included, verify that the path is correct and try again."

We referred to the install doc and a support doc that referred to
required account permissions and installed tools but we confirmed that
to all still be valid in the environment.

We have tried running the IDM service as both a service account and as
the local system account, both approaches resulted in the same error.

Any other reasons why this error would be thrown? It seems the service
isn't loading the PowerShell commands properly but we have communication
to AD via the driver config, communication to Exchange verified through
the PowerShell client, authentication because the driver and the service
successfully start and authorization confirmed through the PowerShell

gdrtx's Profile: https://forums.netiq.com/member.php?userid=1660
View this thread: https://forums.netiq.com/showthread.php?t=51442