Hey all,

I am trying to work with Remote Loader 4.0.2 on Windows 2012.
The service IDMEx2010Service.exe is installed.
Remote Loader is patched with IDM402_Engine_RL_P2 and idm402ad4002.
AD has RSAT feature and Exchange Management tools installed.

I manage to run any exchange cmdlet from Exchange Management shell, like
enable-mailbox get-mailbox ..., without any problem.
When I am trying to do the same via AD driver I get "Exchange 2010
Exception. code:0x00000628 Error".

On Windows 2008 R2 the same configuration works properly.

Any ideas how to solve it?

Trace example:
-[10/15/13 10:35:03.657]:Exchange Driver ST:Remote Interface Driver:
Sending...
[10/15/13 10:35:03.658]:Exchange Driver ST:
<nds dtdversion="4.0" ndsversion="8.x">
<source>
<product edition="Standard" version="4.0.2.0">DirXML</product>
<contact>Novell, Inc.</contact>
</source>
<input>
<add cached-time="20131015083459.789Z" class-name="user"
event-id="idm-qa#20131015083458#2#1:89448f56-65ba-451b-6cb5-568f4489ba65"
qualified-src-dn="O=Users\OU=Employees\CN=123456789"
src-dn="\META-TEST\Users\Employees\123456789" src-entry-id="117416"
timestamp="1381826098#2">
<add-attr attr-name="MMTUser">
<value timestamp="1370783208#121" type="string">DIMAD</value>
</add-attr>
</add>
<modify class-name="User"
dest-dn="CN=DIMAD,OU=Users,OU=M,OU=MT,DC=MTlab,DC=com"
event-id="idm-qa#20131015083458#2#1:89448f56-65ba-451b-6cb5-568f4489ba65">
<modify-attr attr-name="PSExecute">
<remove-all-values/>
<add-value>
<value type="string">Enable-Mailbox -Identity DIMAD -Alias
DIMAD</value>
</add-value>
</modify-attr>
</modify>
</input>
</nds>
[10/15/13 10:35:03.679]:Exchange Driver ST:Remote Interface Driver:
Document sent.
[10/15/13 10:35:03.717]:Exchange Driver :Remote Interface Driver:
Received.
[10/15/13 10:35:03.718]:Exchange Driver :
<nds dtdversion="1.1" ndsversion="8.7">
<source>
<product asn1id="" build="20130813_120000"
instance="\META-TEST\System\DriverSet\Exchange Driver"
version="4.0.0.2">AD</product>
<contact>Novell, Inc.</contact>
</source>
<output>
<status
event-id="idm-qa#20131015083458#2#1:89448f56-65ba-451b-6cb5-568f4489ba65"
level="error" text1="schema violation" type="app-general">
<message>Attribute 'MMTUser' is not in the application schema</message>
<xds-path>/nds/input/add[@event-id='idm-qa#20131015083458#2#1:89448f56-65ba-451b-6cb5-568f4489ba65'][@class-name='user'][@src-dn='\META-TEST\Users\Employees\123456789'][@class-name='user']</xds-path>
</status>
<status
event-id="idm-qa#20131015083458#2#1:89448f56-65ba-451b-6cb5-568f4489ba65"
level="error" text1="Exchange 2010" type="exchange">Exchange 2010
Exception. code:0x00000628 Error completing exchange 2010 command.
ERROR: The
'C:\Windows\system32\WindowsPowerShell\v1.0\Module s\activedirectory\activedirectory.psd1'
module cannot be imported because its manifest contains one or more
members that are not valid. The valid manifest members are
('ModuleToProcess', 'NestedModules', 'GUID', 'Author', 'CompanyName',
'Copyright', 'ModuleVersion', 'Description', 'PowerShellVersion',
'PowerShellHostName', 'PowerShellHostVersion', 'CLRVersion',
'DotNetFrameworkVersion', 'ProcessorArchitecture', 'RequiredModules',
'TypesToProcess', 'FormatsToProcess', 'ScriptsToProcess', 'PrivateData',
'RequiredAssemblies', 'ModuleList', 'FileList', 'FunctionsToExport',
'VariablesToExport', 'AliasesToExport', 'CmdletsToExport'). Remove the
members that are not valid ('HelpInfoUri'), then try to import the
module again.</status>
<status
event-id="idm-qa#20131015083458#2#1:89448f56-65ba-451b-6cb5-568f4489ba65"
level="success"/>
</output>
</nds>-

Best Regards

Dima


--
dimado
------------------------------------------------------------------------
dimado's Profile: https://forums.netiq.com/member.php?userid=3518
View this thread: https://forums.netiq.com/showthread.php?t=48956