We are in the process of upgrading our PeopleTools from version 8.51 to
8.53. In testing this upgrade I got a new set of the CI API files. I am
running IDM 3.6.1 with java 1.6 (x64), so I compiled those files with a
compiler of the same version. The compiler itself reported some
warnings:

warning: psft/pt8/joa/IObject.class(psft/pt8/joa:IObject.class): major
version 51 is newer than 50, the highest major version supported by this
compiler.
It is recommended that the compiler be upgraded.
warning:
psft/pt8/joa/JOAException.class(psft/pt8/joa:JOAException.class): major
version 51 is newer than 50, the highest major version supported by this
compiler.
It is recommended that the compiler be upgraded.
2 warnings

I didn't like that, so I compiled with java 7, and I didn't get any of
those warnings.

As a test I decided to generate 2 sets of jar files with the CI APIs.
One compiled with java 6 and the other with java 7. When I tried to test
those files using the CITester tool, I got the error "Unsupported
major.minor version 51.0."

I ran the CITester tool with the java under ../lib64/nds-modules/jre and
the dirxmlcomps.jar file from the ../lib64/dirxml/classes directory.

As another test I ran the CITester tool with java 7, I didn't have any
problem.

Is this newer version of PeopleTools not compatible with IDM 3.6.1 which
means I will have to upgrade to IDM 4.0.2?


--
celsolima
------------------------------------------------------------------------
celsolima's Profile: https://forums.netiq.com/member.php?userid=260
View this thread: https://forums.netiq.com/showthread.php?t=49269