Hi All,

I am trying to call ID provider driver from a Loopback driver to get
Next ID value. But every time the ID provider driver returns -1.Though
the ID Provider driver is in running state.

The log from Loopback Driver:

[10/24/14 05:05:54.751]:lb.txt ST: Evaluating selection criteria for
rule 'r2'.
[10/24/14 05:05:54.751]:lb.txt ST: (if-operation equal "add") =
TRUE.
[10/24/14 05:05:54.751]:lb.txt ST: Rule selected.
[10/24/14 05:05:54.751]:lb.txt ST: Applying rule 'r2'.
[10/24/14 05:05:54.751]:lb.txt ST: Action:
do-set-local-variable("nextid",scope="policy",token-xpath("id:getNextID("10.0.0.191","1199","wfid","Lo opback
Driver","4"
)")).
[10/24/14 05:05:54.751]:lb.txt ST:
arg-string(token-xpath("id:getNextID("10.0.0.191","1199","wfid","Lo opback
Driver","4")"))
[10/24/14 05:05:54.751]:lb.txt ST:
token-xpath("id:getNextID("10.0.0.191","1199","wfid","Lo opback
Driver","4")")
[10/24/14 05:05:54.768]:lb.txt ST: Token Value: "-1".
[10/24/14 05:05:54.768]:lb.txt ST: Arg Value: "-1".
[10/24/14 05:05:54.768]:lb.txt ST:Policy returned:



The log from ID Provider Driver:

DirXML Log Event -------------------
Driver: \BWLD-IDV-DEV\System\BWW_DriverSet\id-provider
Channel: Subscriber
Object: \BWLD-IDV-DEV\BWW\Contractors\testc007
Status: Error
Message: Got invalid ID "-1" from ID-Server for
"\BWLD-IDV-DEV\BWW\Contractors\testc007". The ID has not been written to
the object.
[10/24/14 05:05:54.741]:ID.txt ST:End transaction.
[10/24/14 05:05:54.767]:ID.txt :IDProviderShim: getNextID()
[10/24/14 05:05:54.767]:ID.txt :IDProviderShim: Error: policy "wfid" not
registered.
[10/24/14 05:05:54.767]:ID.txt :IDProviderShim: ID: -1 [Loopback
Driver]


Please share your thought.


Thanks
Joydeep Mukherjee


--
joydeep9j
------------------------------------------------------------------------
joydeep9j's Profile: https://forums.netiq.com/member.php?userid=4754
View this thread: https://forums.netiq.com/showthread.php?t=52032