Hi all: We are a NOWS customer and we are starting to upgrade our servers from OES2 to OES11. With the upgrade I want to be on the latest version of IDM. Is 3.6 still the latest bundled version of IDM?