I had been trying to get an Office365 driver to run on a Windows 2008 R2
server. After trying combinations of the 64-bit DLLs provided with the
64-bit Powershell module package and going nowhere, I decided to try to
use the 32-bit versions of the same DLLs considering the remote loader
itself is a 32-bit application. To my surprise the driver started

The following is what I did with the 32-bit DLLs. The same procedure
with the 64-bit DLLs before I tried the 32-bit DLLs led me nowhere. I
was getting the error that is reported in the TID 7015184 but did not
apply to my case.

Just like the documentation states I added the following 2 files to the
Novell\remoteloader.net folder. Tried to start the driver but it died
with the error reported in the TID.

Microsoft.Online.Administration.Automation.PSModul e.dll
Microsoft.Online.Administration.Automation.PSModul e.Resources.dll

Then I added the following (based on some input from a user in the
forums), but I still got the same error. Although I appreciate the
contribution, I wish the person had been more forthcoming with some more
information considering there a consultant involved.

Microsoft.Azure.ActiveDirectory.Client.Framework.d ll

Finally I wondered if the fact that my environment is federated required
me to also add the federation modules listed below. I tried that and the
driver came on.

Microsoft.Online.Identity.Federation.PowerShell.dl l
Microsoft.Online.Identity.Federation.PowerShell.dl l-help.xml
Microsoft.Online.Identity.Federation.PowerShell.St rings.dll

Has that been documented anywhere, and I didn't read it correctly that
we need to use the 32-bit version of those DLL's?

celsolima's Profile: https://forums.netiq.com/member.php?userid=260
View this thread: https://forums.netiq.com/showthread.php?t=52169