Did anyone manage to get Office365 driver going at all?

I am getting the following error:

Cannot convert 'Sy
stem.String' to the type 'System.Nullable`1[System.Boolean]' required by
parameter 'StrongPasswordRequired'. </message>
<exception-type>ParameterBindingException</exception-type>
<stack-trace> at
System.Management.Automation.ParameterBinderBase.C oerceTypeAsNeeded(CommandParameterInternal
argument, String parameterN
ame, Type toType, ParameterCollectionTypeInformation collectionTypeInfo,
Object currentValue)
at
System.Management.Automation.ParameterBinderBase.B indParameter(CommandParameterInternal
parameter, CompiledCommandParameter parameterMet
adata, ParameterBindingFlags flags)
at
System.Management.Automation.CmdletParameterBinder Controller.BindParameter(CommandParameterInternal
argument, MergedCompiledCommandParam
eter parameter, ParameterBindingFlags flags)
at
System.Management.Automation.CmdletParameterBinder Controller.BindParameter(UInt32
parameterSets, CommandParameterInternal argument, Merg
edCompiledCommandParameter parameter, ParameterBindingFlags flags)
at
System.Management.Automation.CmdletParameterBinder Controller.BindParameters(UInt32
parameterSets, Collection`1 arguments, CommandMetadat
a commandMetadata)
at
System.Management.Automation.CmdletParameterBinder Controller.BindCommandLineParametersNoValidation(C ollection`1
arguments)
at
System.Management.Automation.CmdletParameterBinder Controller.BindCommandLineParameters(Collection`1
arguments)
at
System.Management.Automation.CommandProcessor.Bind CommandLineParameters(CommandParameterInternal[]
parameters)
at
System.Management.Automation.CommandProcessor.Prep are(CommandParameterInternal[]
parameters)
at
System.Management.Automation.CommandProcessorBase. DoPrepare(CommandParameterInternal[]
parameters)
at
System.Management.Automation.Internal.PipelineProc essor.Start(Boolean
incomingStream)
at
System.Management.Automation.Internal.PipelineProc essor.SynchronousExecuteEnumerate(Object
input, Hashtable errorResults, Boolean enumer
ate)&lt;/stack-trace></msg><timestamp>1390271130526</timestamp></result>

The only way I was able to make the driver work was to remove the GCV
definition of the StrongPasswordRequired completely by deleting the
following:

<definition display-name="Set Strong Password Required"
name="StrongPasswordRequired" type="boolean">
<description>Set this value to true to enforce strong password
requirement for a user password. </description>
<value>false</value>

And updating the driver in the IDV, but then users have to have strong
passwords, which is not the case at the site I am trying this driver
for.

Looking at the Office365 power shell commands, the
StrongPasswordRequired parameter is a legitimate option when new
office365 user is being created, so I have no idea where else to look.

Any suggestions?


--
lpavic
------------------------------------------------------------------------
lpavic's Profile: https://forums.netiq.com/member.php?userid=4395
View this thread: https://forums.netiq.com/showthread.php?t=49743