I tried to migrate an AD driver from a server running 3.61 to another
running 4.02.

In Designer, I right-click the existing server and select Migrate. It
soon fails with the message

"There are no available target servers to migrate to.

Target servers must be the same version (or newer) than the source
server, which is version 3.6.1, and must not be associated with a
driver set."

I've got two brand new 4.02 servers in the tree.

Can someone tell me what I'm doing wrong and, maybe, how to fix it?