IDM 4.5, fresh install, RL on Win 2008R2.

(Turns out we had forgotten to install the Windows Management Framework
before installing the IDMPowerShell, had to uninstall, install WMF,
reinstall the service, side note, in case you run into this).

Had to get WinRM allowed on the remote Exchange server. I got some good
notes, will do a CS article on all the various errors I collected for
'the next guy'.

But now, I specify a specific Exchange server in the driver config.
(PS: FQDN referenced in the docs and 'help' button means DNS FQDN, not
AD FQDN, a bit confusing).

I can test connectivity with Test-WSMan from RL to Exchange server.

[PS] C:\Windows\system32>Test-WSMan

wsmid :
ProtocolVersion :
ProductVendor : Microsoft Corporation
ProductVersion : OS: 0.0.0 SP: 0.0 Stack: 2.0

But now when I send in a Enable-Mailbox via the driver shim, I get:

DirXML Log Event -------------------
Driver: \ACME-IDV-DEV\system\Driver Set\Active Directory Driver
Channel: Subscriber
Object: \A10-IDV-DEV\com\acme\Users\Active\Employees\bobSmith
Status: Error
Message: Error completing exchange command. ERROR: The term
'Enable-Mailbox' is not recognized as the name of a cmdlet, function,
script file, or operable program. Check the spelling of the name, or if
a path was included, verify that the path is correct and
try again.

I must be missing something AD side that is obvious but not clear to me.

AD guy had to enable WinRM as:

[PS] C:\Windows\system32>winrm e winrm/config/listener [PS]
C:\Windows\system32>winrm quickconfig WinRM already is set up to receive
requests on this machine.
WinRM is not set up to allow remote access to this machine for management.
The following changes must be made:

Create a WinRM listener on HTTP://* to accept WS-Man requests to any IP
on this machine.
Enable the WinRM firewall exception.

Make these changes [y/n]? y

WinRM has been updated for remote management.

Created a WinRM listener on HTTP://* to accept WS-Man requests to any IP
on this machine.
WinRM firewall exception enabled.
[PS] C:\Windows\system32>winrm e winrm/config/listener Listener
Address = *
Transport = HTTP
Port = 5985
Enabled = true
URLPrefix = wsman
ListeningOn =,,, ::1,
fe80::100:7f:fffe%14, fe80::5efe:, fe80::25

Do we need to do anything else?