I have a PowerShell script that creates a HomeDrive, HomeDirectory. When
I run the script in Windows PowerShell, It works fine, But I run this
through AD Driver, get this error-->

<status event-id="Active Directory Driver##14ba6849b35##0" level="error"
text1="Exchange 2010" type="powershell">Exchange 2010 Exception.
code:0x0000274d Connnection Error. Make sure service is
Running</status>

LOG :
</add-value>
</modify-attr>
<modify-attr attr-name="PSExecute">
<add-value>
<value type="string">$ACL.Access | ForEach {
[Void]$ACL.RemoveAccessRule($_) }</value>
</add-value>
</modify-attr>
<modify-attr attr-name="PSExecute">
<add-value>
<value type="string">$ACL.AddAccessRule((New-Object
System.Security.AccessControl.FileSystemAccessRule ("$NTDomain\Domain
Admins","FullControl", "ContainerInherit, ObjectInherit", "None",
"Allow")))</value>
</add-value>
</modify-attr>
<modify-attr attr-name="PSExecute">
<add-value>
<value type="string">$ACL.AddAccessRule((New-Object
System.Security.AccessControl.FileSystemAccessRule ("$NTDomain\F00004","Modify",
"ContainerInherit, ObjectInherit", "None", "Allow")))</value>
</add-value>
</modify-attr>
<modify-attr attr-name="PSExecute">
<add-value>
<value type="string">Set-Acl \\fs01\users\SEW\SFH\F00004
$ACL</value>
</add-value>
</modify-attr>
</modify>
</input>
</nds>
[02/20/15 04:24:58.781]:ad ST:Remote Interface Driver: Document sent.
[02/20/15 04:24:59.918]:ad :Remote Interface Driver: Received.
[02/20/15 04:24:59.918]:ad :
<nds dtdversion="1.1" ndsversion="8.7">
<source>
<product asn1id="" build="20120330_120000"
instance="\DEVVAULT\system\services\Driver Set\Active Directory Driver"
version="4.0.0.0">AD</product>
<contact>Novell, Inc.</contact>
</source>
<output>
<status event-id="Active Directory Driver##14ba6849b35##0"
level="error" text1="Exchange 2010" type="powershell">Exchange 2010
Exception. code:0x0000274d Connnection Error. Make sure service is
Running</status>
<status event-id="Active Directory Driver##14ba6849b35##0"
level="success"/>
</output>
</nds>
[02/20/15 04:24:59.919]:ad :Remote Interface Driver: Received document
for subscriber channel
[02/20/15 04:24:59.919]:ad :Remote Interface Driver: Waiting for
receive...
[02/20/15 04:24:59.919]:ad ST:SubscriptionShim.execute() returned:
[02/20/15 04:24:59.920]:ad ST:
<nds dtdversion="1.1" ndsversion="8.7">
<source>
<product asn1id="" build="20120330_120000"
instance="\DEVVAULT\system\services\Driver Set\Active Directory Driver"
version="4.0.0.0">AD</product>
<contact>Novell, Inc.</contact>
</source>
<output>
<status event-id="Wheaton Active Directory Driver##14ba6849b35##0"
level="error" text1="Exchange 2010" type="powershell">Exchange 2010
Exception. code:0x0000274d Connnection Error. Make sure service is
Running</status>
<status event-id="Wheaton Active Directory Driver##14ba6849b35##0"
level="success"/>
</output>
</nds>
[02/20/15 04:24:59.922]:ad ST:Processing returned document.
[02/20/15 04:24:59.922]:ad ST:Processing operation <status> for .
[02/20/15 04:24:59.922]:ad ST:
DirXML Log Event -------------------
Driver: \DEVVAULT\system\services\Driver Set\Active Directory
Driver
Channel: Subscriber
Status: Error
Message: Exchange 2010 Exception. code:0x0000274d Connnection
Error. Make sure service is Running

Any one have any ideas, How to solve this problem?


--
arnab_majumdar
------------------------------------------------------------------------
arnab_majumdar's Profile: https://forums.netiq.com/member.php?userid=9123
View this thread: https://forums.netiq.com/showthread.php?t=52885