Home

Results 1 to 10 of 10

Thread: Workflow Not launching Error

  1. #1
    Join Date
    Sep 2008
    Posts
    25

    Workflow Not launching Error


    I am working with someone one workflows. We are trying to launch one
    workflow from another via WSDL and we are getting an error.

    I not that familiar with workflows so I thought I would post this to
    get opinions. Any Ideas ? I know it might have to with a password
    because of the Unauthorized but not sure which one. I am new to this
    whole workflow thing and I know the fourms is the place to go for answer
    and suggestions !!

    THANK YOU !!


    EST Workflow Error: Process requestId
    [d3b40a4fd2b74af0ab0d8d741bf14a22], Id
    [cn=AddUserAccountEntitlement,cn=RequestDefs,cn=App Config,cn=UserApplication,cn=NGCDriverSet,ou=idm,o u=services,o=ngc],
    Integration activity [Activity3]: faulted [<?xml version="1.0"
    encoding="UTF-8"?><m:FaultInfo
    xmlns:m="http://novell/extendComposer/SystemFault">
    <mateTime>Mon Nov 21 15:21:33 EST 2011</mateTime>
    <m:ComponentName>Identity Vault_UserApplication_Add UserAccount
    Entitlement_Activity3</m:ComponentName>
    <m:MainCode>-1</m:MainCode>
    <m:SubCode>1</m:SubCode>
    <m:Message>com.sssw.b2b.rt.GNVException: rt007005:Error encountered
    executing WSDL Action:;
    ---&gt; nested java.rmi.RemoteException: HTTP 401
    Unauthorized</m:Message>
    </m:FaultInfo


    --
    Driver_Girl
    ------------------------------------------------------------------------
    Driver_Girl's Profile: http://forums.novell.com/member.php?userid=30126
    View this thread: http://forums.novell.com/showthread.php?t=448557


  2. #2
    Join Date
    Dec 2007
    Location
    Brooklyn, NY
    Posts
    6,213

    Re: Workflow Not launching Error

    The account used to log in via SOAP/WSDL needs to be a Provisioning
    Admin Role holder. It seems a bit extreme to require quite so many
    rights, but dems de breaks.


    > I am working with someone one workflows. We are trying to launch one
    > workflow from another via WSDL and we are getting an error.
    >
    > I not that familiar with workflows so I thought I would post this to
    > get opinions. Any Ideas ? I know it might have to with a password
    > because of the Unauthorized but not sure which one. I am new to this
    > whole workflow thing and I know the fourms is the place to go for answer
    > and suggestions !!
    >
    > THANK YOU !!
    >
    >
    > EST Workflow Error: Process requestId
    > [d3b40a4fd2b74af0ab0d8d741bf14a22], Id
    > [cn=AddUserAccountEntitlement,cn=RequestDefs,cn=App Config,cn=UserApplication,cn=NGCDriverSet,ou=idm,o u=services,o=ngc],
    > Integration activity [Activity3]: faulted [<?xml version="1.0"
    > encoding="UTF-8"?><m:FaultInfo
    > xmlns:m="http://novell/extendComposer/SystemFault">
    > <mateTime>Mon Nov 21 15:21:33 EST 2011</mateTime>
    > <m:ComponentName>Identity Vault_UserApplication_Add UserAccount
    > Entitlement_Activity3</m:ComponentName>
    > <m:MainCode>-1</m:MainCode>
    > <m:SubCode>1</m:SubCode>
    > <m:Message>com.sssw.b2b.rt.GNVException: rt007005:Error encountered
    > executing WSDL Action:;
    > ---&gt; nested java.rmi.RemoteException: HTTP 401
    > Unauthorized</m:Message>
    > </m:FaultInfo
    >
    >



  3. #3
    Join Date
    Sep 2008
    Posts
    25

    Re: Workflow Not launching Error


    Thanks I am going to forward this off to my workflow developers and try
    this.

    Thank you very much !!!


    --
    Driver_Girl
    ------------------------------------------------------------------------
    Driver_Girl's Profile: http://forums.novell.com/member.php?userid=30126
    View this thread: http://forums.novell.com/showthread.php?t=448557


  4. #4
    Join Date
    Feb 2008
    Posts
    136

    Re: Workflow Not launching Error


    geoffc;2155577 Wrote:
    > The account used to log in via SOAP/WSDL needs to be a Provisioning
    > Admin Role holder. It seems a bit extreme to require quite so many
    > rights, but dems de breaks.
    >
    >
    > > I am working with someone one workflows. We are trying to launch

    > one
    > > workflow from another via WSDL and we are getting an error.
    > >
    > > I not that familiar with workflows so I thought I would post this to
    > > get opinions. Any Ideas ? I know it might have to with a password
    > > because of the Unauthorized but not sure which one. I am new to

    > this
    > > whole workflow thing and I know the fourms is the place to go for

    > answer
    > > and suggestions !!
    > >
    > > THANK YOU !!
    > >
    > >
    > > EST Workflow Error: Process requestId
    > > [d3b40a4fd2b74af0ab0d8d741bf14a22], Id
    > >

    > [cn=AddUserAccountEntitlement,cn=RequestDefs,cn=App Config,cn=UserApplication,cn=NGCDriverSet,ou=idm,o u=services,o=ngc],
    > > Integration activity [Activity3]: faulted [<?xml version="1.0"
    > > encoding="UTF-8"?><m:FaultInfo
    > > xmlns:m="http://novell/extendComposer/SystemFault">
    > > <mateTime>Mon Nov 21 15:21:33 EST 2011</mateTime>
    > > <m:ComponentName>Identity Vault_UserApplication_Add UserAccount
    > > Entitlement_Activity3</m:ComponentName>
    > > <m:MainCode>-1</m:MainCode>
    > > <m:SubCode>1</m:SubCode>
    > > <m:Message>com.sssw.b2b.rt.GNVException: rt007005:Error encountered
    > > executing WSDL Action:;
    > > ---> nested java.rmi.RemoteException: HTTP 401
    > > Unauthorized</m:Message>
    > > </m:FaultInfo
    > >
    > >


    You can change this, but it requires you to hack into the WAR file to
    do so. The instructions are in the docs, somewhere. Once you do this,
    you can use trustees assigned to the workflow to start them via SOAP.


    --
    tse7147
    ------------------------------------------------------------------------
    tse7147's Profile: http://forums.novell.com/member.php?userid=4730
    View this thread: http://forums.novell.com/showthread.php?t=448557


  5. #5
    Join Date
    Sep 2008
    Posts
    25

    Re: Workflow Not launching Error


    This is the ba-fuddling part. We are using the same user from another
    workflow to launch another workflow and it works just fine. So I am
    wondering if its something specific to the workflow ? The intergration
    activity ? Any information I can provide or check to help with this ?

    Thanks everyone for your input and time,
    Driver_Girl


    --
    Driver_Girl
    ------------------------------------------------------------------------
    Driver_Girl's Profile: http://forums.novell.com/member.php?userid=30126
    View this thread: http://forums.novell.com/showthread.php?t=448557


  6. #6
    Join Date
    Dec 2007
    Location
    Brooklyn, NY
    Posts
    6,213

    Re: Workflow Not launching Error


    > You can change this, but it requires you to hack into the WAR file to
    > do so. The instructions are in the docs, somewhere. Once you do this,
    > you can use trustees assigned to the workflow to start them via SOAP.


    Neat! Do you have a link to the docs about this? Good to know!

    Does this apply to the do-start-workflow token as well? (ought to,
    since it ought to just be a SOAP wrapper, but I wonder if they did
    something else as well in the token).


  7. #7
    Steven Williams NNTP User

    Re: Workflow Not launching Error

    On 11/22/2011 11:26 AM, Driver Girl wrote:
    >
    > This is the ba-fuddling part. We are using the same user from another
    > workflow to launch another workflow and it works just fine. So I am
    > wondering if its something specific to the workflow ? The intergration
    > activity ? Any information I can provide or check to help with this ?
    >
    > Thanks everyone for your input and time,
    > Driver_Girl
    >
    >

    Why are you using the Integration Activity? We added the Start
    Workflow activity so that you would not need to use the Integration
    Activity.

    --
    Sincerely,
    Steven Williams
    Lead Software Engineer
    NetIQ

  8. #8
    Wolfgang Schreiber NNTP User

    Re: Workflow Not launching Error

    I guess we're talking about Ch. 18.1.2 "Removing Administrator
    Credential Restrictions" in the Admin Guide

    Wolfgang

    On 22.11.2011 18:34, Geoffrey Carman wrote:
    >
    >> You can change this, but it requires you to hack into the WAR file to
    >> do so. The instructions are in the docs, somewhere. Once you do this,
    >> you can use trustees assigned to the workflow to start them via SOAP.

    >
    > Neat! Do you have a link to the docs about this? Good to know!


  9. #9
    Join Date
    Dec 2007
    Location
    Brooklyn, NY
    Posts
    6,213

    Re: Workflow Not launching Error

    On 11/22/2011 1:08 PM, Wolfgang Schreiber wrote:
    > I guess we're talking about Ch. 18.1.2 "Removing Administrator
    > Credential Restrictions" in the Admin Guide


    Neat. Thanks!

    > On 22.11.2011 18:34, Geoffrey Carman wrote:
    >>
    >>> You can change this, but it requires you to hack into the WAR file to
    >>> do so. The instructions are in the docs, somewhere. Once you do this,
    >>> you can use trustees assigned to the workflow to start them via SOAP.

    >>
    >> Neat! Do you have a link to the docs about this? Good to know!



  10. #10
    Join Date
    Sep 2008
    Posts
    25

    Re: Workflow Not launching Error


    That worked and it was much simplier !! Kudos thanks for the direction
    !!

    Driver_Girl


    --
    Driver_Girl
    ------------------------------------------------------------------------
    Driver_Girl's Profile: http://forums.novell.com/member.php?userid=30126
    View this thread: http://forums.novell.com/showthread.php?t=448557


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •